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1 S-Web Editor Help

1.1 Abbreviations

HMI Human Machine Interface, i.e. a PCD.Web-Server view displayed at a
Web panel or PC browser.

*.prj File extension for a PCD.Web-Server project file generated by the
S-Web editor.
A PCD Web-Server project includes everything to form a HMI on a
touch panel or in a browser.

View A view is what the user of a HMI sees at one moment inside a
window or a browser. A *.teq file implements a view.

*.teq File extension for a PCD. Web-Server view file generated by the S-
Web Editor.

*.tcr File extension for the Web-Editor PPO variable initialisation file. It
contains all PCD-Variables of the Web-Editor project with its
definitions for the display format and input ranges.

*.itq File extension for the Web-Editor Container variable initialisation file.
It contains all container variables of the Web-Editor project with its
initialisation values.

*.esm File extension for a S-Web Editor macro object.

*.tlb Since version 5.12 the editor creates macro files with *.esm file
extension. The editor is backward compatible with *.tlb files which is
the old macro format.

Painter A painter is a graphic object, which is used by the S-Web Editor.
This object is programmed in JAVA. Several painters were packed
into an Applet that resides on an embedded system.

Applet A Java program, which can be launched in a browser from within a
HTML page.

PPO Process Point: A process point corresponds to a PCD variable (R, T/
C, F, I/O,…) that is used within the Web application

Container A Container is a local variable, which has a scope within the actual
applet/view. Containers are used to exchange values between
different painters in a view or between different views of the same
applet

IMaster.jar File that contains all the required java classes used in the applet as
well as the main class which starts the applet

 

 

1.2 Installation

For Windows 32 Bit Operating Systems

The S-Web Editor software is written for use on Microsoft 32 Bit Operating
Systems. The installation script will automatically install all components needed
for operation.

The S-Web Editor can be found on the Saia®PG5 Controls Suite CD Rom and is
installed directly from the CD navigation page (start.htm).

The installation script can also be started manually from the CD Rom by starting
the setup program from the Web-Editor directory:

\Web-Editor\Setup.exe
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The S-Web Editor will be installed as add on-tool for PG5.
Please note that a user-key that contains the Web-Editor license is required.

System Requirements

The S-Web Editor runs on Windows 95/98/ME/NT/2000. For good performance, we
recommend using it on Pentium processors with at least 300MHz clock frequency
and at least 64MB of RAM. The Editor requires about 10MB of hard disk space.
Resolution of at least 1024x768 or better is recommended.
A PG5 version 1.3 or higher is required.

Avoid Problems By Disabling Caching In the Sun Java Virtual
Machine

The IMaster Java Applet sends HTTP GET and POST Requests to communicate
with the PLC's web server. The responses to these requests are generated
dynamically.
To avoid that the Sun Java Virtual caches these dynamically generated responses,
you have to deactivate the caching in your system's control panel:

1.Start->Settings->Control Panel

2.Click on the Java icon

3.Choose the 'General' tab

4.Click on 'Settings'
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5.Click on 'Delete Files...'

6.Deactivate the checkbox 'Keep temporary files on my computer'
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7.Confirm with 'OK'

 

 

1.3 Introduction

Creating Web-Server Based HMI's

Thank you for choosing Saia®S-Web technology.

This manual describes the features and use of the Saia®S-Web Editor as add on-
tool with the Saia®PG5 programming utilities. With the S-Web Editor, dynamic
web pages for the Saia®PCD.Web-Server can be created very easily.

Continuous integration and use of Saia®PCD.Web technology is changing the
automation environment in the areas of commissioning, service, control and
monitoring.

Web Browser As Tool For Commissioning And Service

Although most systems, installations and equipment are currently still
commissioned and serviced with specific, proprietary software tools, the use of
web technologies now enables the latter to be replaced with standard tools, such
as Internet Explorer. No specialist know-how is required to operate a browser, and
user acceptance is high. Predefined HTML pages allow optimized device and
system management during commissioning and service. Specific HTML pages for
different user groups also significantly increase convenience and safety, at the
same time greatly reducing costs.

Control And Monitoring With Web Technology

Even for simple control and monitoring functions, costly and often complex Scada
systems have been used. These tasks are ideally suited to the use of a web server
and browser, avoiding the costs of expensive development tools and runtime
licenses. Another advantage of web technology is the vendor-independent,
standard interface between the control system and management level.

Create Java-Based Web Pages Easily, With The Convenient S-Web
Editor

S-Web editor for creation of dynamic, graphical web pages for the Saia®PCD.
Web-Server by simply placing graphical objects and setting their parameters. No
knowledge of HTML or Java programming is required. The graphical objects are
specially adapted to Saia PCD devices. The S-Web editor is an integral part of
Saia PG5 programming tool.

Continuous Access Via Any Preferred Interfaces And Networks

Access to the Web-Server in Saia®PCD devices is possible not only via Ethernet-
TCP/IP, but also via economical, standard serial ports (RS232, RS485, modem ...)
or Profibus networks. All this takes place continuously across the different network
levels.
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Saia®PCD.Web-Server Integrated In All Products

Since 2000, a Web-Server has been integrated in the base units of all new Saia
controllers (such as PCS1, PCD2, 3, 4 and PCD3.RIO) at no extra cost.

Basic Principles Of Saia®S-Web

Web-Server

The Web-Server is the heart of the entire Saia®S-Web concept. The Web-Server is
integrated in the base unit of all new Saia controllers and remote I/Os. It sends
HTML pages and java applets (and any necessary images or other files) requested
by the Web-Browser across the configured communication interface to the PC or
Web-Panel. A Web-Panel is a touch screen panel with browser functionality for the
industrial automation market.
HTML pages, Teq-View files, java applet, images or any other files are stored in the
user program memory of the PCD. They belong to the user program and so are
downloaded from the PG5.

Web-Connect

The Web-Connect PC driver program manages the communication between the PC
or Web-Panel and the PCD/PCS system. Access to the Web-Server in Saia®PCD
devices is possible not only via Ethernet TCP/IP, but also via economical, standard
serial ports (RS232, RS485, modem ...) or Profibus networks. All this takes place
continuously across the different network levels.
The local directory is a directory on the PC/Web-Panel, where the Web-Connect
software is running.
It is possible to save large files (e.g. images, java applet,…) in this directory, which
we don't want to save in the PCD.Web-Server. By this upload time in the browser
and PCD memory space can be reduced.
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Web-Browser

Microsoft Internet Explorer 5.5 or Netscape Navigator 6 can be used to display
Saia®PCD.Web pages. A java virtual machine 1.17 or better is required to display
the Web-Editor pages.

S-Web-Editor

The S-Web Editor allows the creation of dynamic java based web pages for the
Saia®PCD. Web-Server by simply placing graphical objects and setting their
parameters. No knowledge of HTML or Java programming is required. The graphical
objects are specially adapted to Saia PCD devices. The S-Web Editor can be used
in standalone or as add on-tool with Saia®PG5 programming tool. As add on-tool it
is an integral part of PG5 and offers a lot of advantages like direct use of PG5
symbols. The output of the Web-Editor is a java applet, which is called from a main
html page. For each view (browser screen) an individual configuration file (*.teq) for
the java applet is created.

Web-Builder

The Saia®Web-Builder is a PG5 add on-tool for the management of Saia®PCD.
Web-Server projects.
All files (HTML pages, Teq-View files, java applet, images, etc.), which need to be
stored in the PCD.Web-Server must be converted with the web-builder into a PG5
compatible source file format. During the PG5 build process the PCD.Web-Server
content and specific PCD-Web-Server settings are compiled in the same time as
the whole PG5 project. The Web-Server content is downloaded with the PG5
downloader to the PCD device.

File Structure & Formats
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This section explains the project structure and the files which are necessary to
produce a Saia®PCD.Web-Server application with the Web-Editor.
The PCD.Web-Server project is individual for each CPU and is stored in the PG5
Project directory (e.g. C:\PG5 Projects\Project name\CPU Name\..) of the
corresponding CPU. The Web-Editor uses two different directories in the CPU
Project directory:

…\web is the working directory of the Web-Editor. It contains all files created with
the Web-Editor. When starting the Editor from PG5 it uses these files for editing
the project. Note that the PG5 symbol names in the *.teq files are uncompiled long
symbol names. The teq-files from this directory can therefore not be used for the
PCD.Web-Server content.

…\html is the PCD. Web-Server directory, which contains all files that can be
selected and generated with the Web-Builder for the PCD. Web-Server content.
The PG5 symbol names in the teq-files are precompiled short symbol names. The
files (*.html, *.itq, *.tcr, *.teq, *.gif, IMaster.jar) are generated or copied
automatically by the Web-Editor. Note that they are only generated and saved
when saving the project with the "Build All" command. The html file is generated
using the html button or the 'Generate html...' command. Any other files (e.g. text
files), which should also be part of the PCD. Web-Server content can/must be
copied manually in this directory.

To display a PCD.Web-Server project (created with the Web-Editor) the browser
accesses a HTML file that contains a reference to use the Java-Applet.
Furthermore, it contains reference tags to the *.teq files, which represent the views
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that are designed by the user with the Web-Editor. The HTML file is generated by
the Web-Editor (Menu command "Generate HTML")

All Java class files are stored in a so-called Java-archive with the name 'IMaster.
jar'.

To enable a PCD.Web-Server application the following files must be generated with
the Web-Builder into the PCD.Web-Server content:

All teq files that are created by the Web-Editor

All HTML files that are generated by the Web-Editor

Variables initialisation files *.tcr and *.itq

The following files can either be generated with the Web-Builder or they can be
copied to the local directory of the Web-Connect PC.

Additional user-written HTML files (optional)

Image files (*.gif) that are used by the applet or by user-written HTML sources

The java class library IMaster.jar, which is distributed together with the Web-
Editor

The Web-Editor supports also the creation of macro painter objects (*.esm files)
which can be stored in a macro library directory ('MacroLib'). For the library
directory any name can be given. When creating a Web project, macros can be
stored and read into/from the macro library. A macro is based on standard painter
objects that are grouped using the group function of the Web-Editor and then saved
as macro in the macro library.

 

 

 

1.4 Getting Started

Supported Platforms*
- Java Applet
- MicroBrowser
- NanoBrowser

* Refers to all functions described in this chapter

A new PG5 project is first created as explained in the User Manual PG5 26/732.
Create a new program file, which is the same procedure as creating a new IL,
FUPLA, Graftec file etc., except that you choose the file type as Web Editor (.prj),
as shown below:
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A new Web Editor Project is created by pressing OK:

This is the main window of the S-Web Editor application. It controls all the other
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windows and is used to do basic settings.

All files belonging to this project will be added to the PG5 project under a sub
directory called 'Web'.

Creating A New View

The next step will be to add new views to the project. This can be done using the
Project->Add->New menu or with the 'New File' button from the topmost

toolbar. The editor will propose a name, which consists of the project name and an
index.

After that, you can start to enter graphical objects to your new view. You can
choose a variety of objects from the painter toolbar. The meaning of the buttons is
described in the Painter Reference.

Adding A Static Text Or Reading A Process Variable

In the tutorial, a 'Static Text' painter object was selected. The object can be placed
in the view by pressing the left mouse button to mark the left most top position of
the text, then keeping the mouse down and dragging towards the rightmost down
position, then releasing the button. The user now might want to change the text.
This is done by double-clicking the text object. This will open the object properties
dialog box. This dialog box contains different tabs, which allow the user to define
all properties of this object. The first tab 'General' contains options, which are
applicable to any object, e.g. position, size, colours and font. The second tab
'Repaints' lets the user define what the object will show on the screen. In the
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tutorial, a string containing the text 'Welcome To The Tutorial' should be shown. To
do so, the 'Edit a Source' checkbox should be selected, the 'Type' in the selection
on the left should be set to 'STRING' and the desired text should be entered in the
name field. The user can now press the 'OK' button to close the dialog.

Alternatively, the type of a 'Static text' painter can be set to HTML_TAG,
CONTAINER or PPO. If type is set to PPO, the 'Static text' painter can be used to
display a process point of your PLC. If you want to read and edit a process point,
then you have to use the 'Editbox' painter that is described in the next chapter
'Editing a Process Variable'.

Editing A Process Variable (PPO)
 

In the next step, an 'Edit Box' element will be added. This object allows reading
and modifying a PCD variable (R,F,C…) inside the view. To do so, the user should
press the 'Edit Box' button in the toolbox and placing the object in the same way
as the 'Static Text' object. Then, a double click on the object will open a dialog
box, where the 'Repaints' tab should be selected.

The 'Edit a Source' checkbox must be selected and the 'Type' choice should be
set to 'PPO', where 'PPO' stands for 'Process Point', indicating that a variable from
the PCD System should be used. In the 'Name' edit field you should now enter a
symbolic name. A valid name could look like 'TempVessel_1'. A global symbol or a
system symbol may be used by pressing the 'Select' button, which opens a dialog
with all the global and system symbols programmed in the PG5. Choose the
symbol that you want to use and press OK or double click on the symbol, which
will then place this symbol in the Name field.
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The 'OK' button of the properties dialog will then save these settings to the view. All
the process points defined in the project can then be configured with the limits
(min and max values), format and unit value (example °C) by opening the process
point dialog using the menu Project ->Init PPOs... These process points are

only linked with the relative addresses, which are the symbols defined in PG5,
when a build is made of the whole project in PG5

Creating A Second View

A second view should now be added the same way. This can be done by the menu
as presented above, or alternatively, simply by pressing the 'New File' button from
the toolbox. The suggested name will be 'Tutorial2.teq' and the file will be added
automatically to the project. The user can also add a text object indicating the text
'This is the second view…' to the file.

Navigating Between Two Views

The next step will be to add buttons, which allows the user to navigate between the
two pages. To do so, the 'Button' object in the toolbar must be selected and the
object should be placed in the view 'Tutorial1.teq'. A double-click will open the
dialog box again, where the 'Repaints' tab should be selected. On this tab, the
user can enter the text that should be displayed on the button. This is done in the
same way as shown with the 'Static Text' object.
Next, the user should go to the 'Actions Jumb' tab, where the 'View Jump'
checkbox must be selected. Inside the 'view name' edit field, the user can now
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enter the name of the view where the button should jump to, e.g. 'Tutorial2.teq'.

Define the button label:

Define the view jump:

A similar button can now be added to the second view 'Tutorial2.teq', where the
name in the action tab should refer to 'Tutorial1.teq'.

Creating An Application

In the next step, the 'HTML' file, which contains the tutorial applet, will be
generated. This can be done with the menu Project->Generate HTML.. or

with the respective button from the toolbox. The S-Web Editor will suggest the
filename Tutorial.html and add the file to the project. Then, all files should be saved
using the menu File->Save All or by pressing the respective button from the

toolbox.

First Test Inside The Browser

The project can now be generated with the PG5 and downloaded to the PLC or
quickly checked directly with a PC-Browser like MS Internet Explorer. Just open
the file
<your projectname>.html from within your browser. Of course process

points (PPOs) will not be linked yet this way.

Before you download your project to the PLC you have to make a 'Build All'.
Choose menu Project->Build All or click on the following icon from the

toolbar:
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('Build All' icon)

 

 

1.5 Using Fore- And Background TEQs

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

Three Layer Concept

Fore- and background files are an advanced feature and not necessary for simple
projects. The idea of using a fore-/background file is based on a three-layer
approach to define a user view. The user can edit each layer separately. The
runtime will merge the three layers to one view. The user can assign a foreground
and a background to each view separately, but their use is an option.

The background view may typically contain controls that are used in an identical
way on many other views. Integrating them in a background will increase the
productivity especially in case of changes. Typical controls to be used in a
background can be function keys, buttons or message lines.

The foreground view is typically used to display splash messages which may
occur during an exception on the PLC. If the user wants to make sure that an alert
will be displayed in all conditions, no matter which view is actually used by the
operator, the same foreground.teq should be added to all views of the project.

The controls used in this layer should therefore be linked with a condition, so in
regular operation, no controls will be visible from the foreground teq.

 
Foreground TEQ

Basically every view can be used as a foreground Teq for one or more other views.
Foreground teqs will overlap the actually loaded view during the runtime. With
foreground teqs it is not necessary to copy parts of your HMI if they occur in more
than one view. For example important warnings or state indicators. For layout
elements you better use background teqs.

Creating A foreground Alarm TEQ

The first step will be to add new views to the project. This can be done using the
Project->Add->New menu or with the 'New File' button from the topmost

toolbar.

Add and configure an alarm
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Please insert the following Painter in your View:

Define the message

Open the property window with a double-click on the added painter.

Replace the String 'STATIC TEXT' with your message:

Example:

Configure the alarm condition

The warning appears if myVar2 is smaller than 25.

Define this condition in the tab 'Repaints':

Define The View As A Foreground TEQ

You can set a view as the default foreground teq for the project, or just for
particular views.

Set a default foreground-teq for your project

Choose the menu Project->Project Configurations…. In the dialog tab

'Project - Teq Configuration' you will find the dropdown 'foreground teq'. Select the



16

Saia-Burgess Controls Ltd. S-Web Editor Help

Using Fore- And Background TEQs

filename of your 'alarm.teq' and confirm with 'OK'.

This setting will affect all views that you create from now on, not the existing ones.
Use the method 'Set a foreground teq for the actual view' if you want to set a
foreground teq for an existing view.

Set a foreground teq for the actual view

Open first the teq view which should have a foreground-teq. In the dialog 
Project->Teq view configurations you can set a foreground teq for the

actually opened view.

Background TEQ

Using background teqs can avoid to copy parts of your HMI if the same elements
occur in more than one view, e.g. layout elements or navigation buttons.



Saia S-Web-Editor Help | © 2009 Saia-Burgess Controls Ltd. | 07.10.2009

Saia-Burgess Controls Ltd. S-Web Editor Help

Using Fore- And Background TEQs

Just like when using foreground teqs, you can also set a view as the default
background teq for a project, or just for particular views. See 'Set a default
foreground-teq for your project'
'Set a foreground teq for the actual view' for details.

Warning: AWT Components appear always in front during runtime so you can't put
other components over these.

 

 

1.6 Initialising Containers

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

A Container is a local variable inside the HMI. They are only visible within one or
more views. By the menu function Project->Init Containers... the

property dialog of the containers will be opened where they can be initialised to a
desired value. Instead of the menu function you can also use the "Init container
vars" button from the topmost toolbar:

All containers are listed here.

You can set the initial value of each Container by clicking into the column "Initial
Value". By leaving the dialog with 'OK' a file called <your_projectname>.itq

will be generated.
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MB_tmz_en and MessageBoxCO are predefined Container variables which are
always present.
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1.7 Initialising Processpoints (PPOs)

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

Init PPO Dialog

Once the Web Editor project has been completed and all the graphical views have
been created, the user must open the 'PPOs Init' dialog using the menu 
Project-> Init PPOs... to be able to complete the configuration of all the

symbols used in the project.

The dialog displays a list of all used symbolical names together with their
configuration. Double click a field of the list and its configuration can be modified.
By leaving the dialog with 'OK' a file called '<your_projectname>.tcr' will be
generated. This file is automatically saved to the PG5 project in the sub directory
'Web'. When a 'Build All' is done with the Web Editor, then this file is copied to the
html sub directory of the PG5 project. The Web Builder needs the html sub
directory in the PG5 project to be able to display all the resources in this sub
directory that could be chosen by the user to download to the PLC. It is important
that '<your_projectname>.tcr' file is chosen with the Web Builder to download it to
the PLC. The meanings of the different fields are as follows:

PPO min Val & PPO max Val

Only used for 'Editbox' painter objects to offer a range check for edited values.
Only values within the range PPO min. Val to PPO max. Val. is accepted by the
'Editbox'.

PPO format Val

For PCD-text make sure having used the 'string' format in the 'init PPO'
dialog
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Defines the display format of a PPO according to the PG5 format definition. An
example of how it is displayed in the browser for each format is shown:

It is very important to define the right format for every PPO! For example a PCD-
text must be defined as 'String' in the 'Init PPO' dialog. Otherwise the
corresponding painter will display the message 'syntax error'.
Please read the chapter 'Error Messages'

PPO Unit Val

String that is displayed together with the PPO and that can be used to indicate the
unit of the PPO.

Examples
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1.8 Container Offset

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

With the 'Container Offset' function you can integrate arrays into an HMI. For
example you have one edit field (source type 'PPO') and an additional one for
the offset (source type 'CONTAINER'). The user can now control which array-
element should be shown by typing 1, 2, 3 or 4 into the edit field with the offset
container.
For the edit field which should show the values of your array, you have to use a
special syntax.

Incremental Container Offset Example
 

1. Insert two 'Edit Box' Painters into a new TEQ-View.

2. Define the source type 'CONTAINER' for one of the inserted edit boxes and
enter a name. At runtime the user can control the offset of the PPO by
entering an integer into this offset 'Edit Box'.

3. Define the source type 'PPO' for the second 'Edit Box'. What you now enter
in the name field is a special syntax:

General syntax for container offset:

Syntax in the case of absolute PDP-addresses:
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The text from the prefix '+@COFF_' until the delimiter '@' will be replaced
with the value of 'ContainerName'.
It assumes the value of the container is an integer value.

If you have PPOs with names like 'my[123].Var'. The 'BasePPOName' would
be 'my[' and the suffix '].Var'.

4. Chose 'Build All' and download your project with PG5.

What will now happen at runtime?

Defined PPO name: PDP,,R1000+@COFF_MyContainer@,d

'PDP,,R1000' is the base PPO address. This base address will now be
incremented by the offset given in the container 'MyContainer'. This happens
because of the keyword '+@COFF_'. The second '@' is the end delimiter.

String Replacement
 

Syntax For The PPO Name
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The text from the prefix '@CO_' until the delimiter '@' will be replaced with the
string in the container 'ContainerName'.

 

1.9 Persistent Containers

Supported Platforms
- MicroBrowser

This chapter is only relevant if you have a MicroBrowser target as a client.
Persistent containers have special names like this:

MB_PERCO_[0...19](for example MB_PERCO_2)

The values of persistent containers are stored permanently on the file system. If
you close MicroBrowser the values of the persistent containers are not lost.
This is very useful if you want to save language settings for example. The
persistent containers have no specific purpose, you can use them for your own
needs.

 

 

1.10 Session Container

Supported Platforms
- Java Applet
- MicroBrowser

Session containers are mentioned to keep an information during the whole
session, even if the user jumps to the HMI of another PLC (URL Jump). There are
20 session containers with predefined names: "_NOINITSESSCO_0" ...
"_NOINITSESSCO_19"

Use them for example to keep user's level given by a Password Entry Page during
the whole session.

The session ends if the user closes the browser client.
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1.11 Special Container Names

Supported Platforms
Please see spreadsheet below

The SpiderControl browser (IMaster Java Applet or MicroBrowser) uses some
special Container variables. The name of these Container variables are reserved.
If you see one of them in the 'Cross Ref' window of a macro, don't modify them and
never reuse the same name.

The special Container variables are listed in this chapter or they have a name
starting with '@MACRO'.

Container-Name Description Suppor
ted by
Java

Applet
Client*

Support
ed by

MicroBr
owser*

Support
ed by

NanoBr
owser

@BLINKCO The SpiderControl browser does
automatically toggle the value of
that container (0/1) at every period.
(read-only)

X X -

@CURRENT_PAG
E

Name of the current TEQ view (read-
only)

X X X

@LAST_PAGE Name of the last TEQ view (read-
only)

X X X
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@FOCUS Please see Set Focus On Gain
Focus macro

- X X

@LANGUAGE Contains the name of the language
CSV file.

X X X

@MB_FKEY_EVE
NT

Last function key (read-only)
X X -

@MB_FULL_RED
RAW

Write '0' or '1' to disable or enable
the full redraw mode

- X -

@MODAL_FOREG
ROUND

Permits to disable or enable the
modal foreground TEQ (0 = disable;
1 = enable).

X X -

AUTOINCRCO This container is automatically
incremented by SpiderControl
browser at every period.
i.e.: Animated GIF macro with
modulo action to define GIF
filename's index.

X X -

IMaster.VERSION IMaster Java Applet version number
(read-only)

X - -

IsWebBrowser Is equals to '0' for browsing with
local file, = '1' for remote access
(read-only)

X X -

MB_APP_VERSIO
N

MicroBrowser version number (read-
only)

- X -

MB_VERSION NanoBrowser version number (read-
only)

- - X

MB_Backlight ** Write 0 or 1 to turn off/on the
display or the LCD backlight

- X -

MB_BringWindowT
oTop **

Write the name of the window, or a
part of the window name, to bring it
on the top. Writing "_self" will bring
the MicroBrowser on top.

- X -

MB_Buzzer ** Write '0' or '1' to disable or enable
the buzzer.

- X -

MB_ExeToTop ** Write the name of the program to
bring on the top into this container.

- X -

MB_FOCUS Get object id (0..n) of the current
focused object or write the the
current focus. '-10' means no
selection.

- X -

MB_Gateway Client's gateway address (read-only) - X -
MB_HEAP1_SIZE Shows the number of bytes used in

Heap1 memory (read-only)
- - X

MB_HEAP2_SIZE Shows the number of bytes used in
Heap2 memory (read-only)

- - X

MB_inactivity_pts_
ms

Refresh period in milliseconds of the
SpiderControl browser's refresh
state 'inactivity'.
Corresponds to the setting of the
'inactivity_pts_ms' defined in the
XML configuration file (uBrowser.
xml).

- X -

MB_inactivity_to_s
ec

Time in seconds until
MicroBrowser's refresh switches to
the state 'inactivity'. The parameter
'MB_inactivity_pts_ms' defines the
refresh period in milliseconds of

- X -
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'inactivity' state.
Corresponds the the setting
'inactivity_to_sec' defined in the XML
configuration file (uBrowser.xml).
Useful to avoid unnecessary
network traffic in case of user
inactivity.

e.g.:
MB_inactivity_pts_ms = 5000
MB_inactivity_to_sec = 60
The refresh period is set to 5000 ms
after 60 sec of inactivity (inacivity
means no user interaction).

MB_InactivityCount
er

This variable increments every
second.
Set to '0' as soon as a user action
occurs. (read-only)
i.e.: Event Timeout Logout Macro
described in the chapter 
Automatical View Jump

X X x

MB_InactivityCount
erMin

This variable increments every
minute. Reset to 0 on any mouse or
key action of the user. Useful for
logout. (read-only)

X X -

MB_IpAddress Client's IP-Address (read-only) - X -
MB_OS_VERSIONVersion identifier of the operating

system (read-only)
- X -

MB_PERCO_0
MB_PERCO_1
...
MB_PERCO_19

Please see chapter 'Persistent
Containers'

- X -

MB_PLATFORM Platform name, which is one of the
following identifiers "uBT", "uBCE",
"uBXP", ... (read-only)

- X -

MB_PollTimeSubst
itute

Allows to set at any time a new
refresh period in milliseconds, (0:
means Client uses the default
refresh period defined in the project).

X X -

MB_SCREEN_HEI
GHT

height of the screen in pixel (read-
only)

- X -

MB_SCREEN_WID
TH

width of the screen in pixel (read-
only)

- X -

MB_StartProcess
**

Write the name of the application to
start. Write "killme" will close the
MicroBrowser program itself.

- X -

MB_Subnet Client's subnet mask (read-only) - X -
MB_tmz_en Switch ('0' or '1') between local time

zone and UTC time (e.g. used in
time indications of trending and
alarming). See 'MicroBrowserSetup.
pdf' for more details.

X X -

MB_UpdateAfterCo
Write

Write '0' or '1' to improve the
reaction time after writing on any
CO

- X -

MB_UpdateAfterPp Write '0' or '1' to improve the
- X -
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oWrite reaction time after writing on any
PPO

MB_Volume ** Defines volume in percent - X -
MB_WakeUp ** Write '1' to wake up the client and to

stop the screen saver
- X -

MessageBoxCO Reserved container used in
message box TEQ view

X X -

MSGBOX_NR Number of messages appended in
the message box

- X -

_KEYEVENT Used by the keypad TEQ to append
new characters

- X -

_KEYPAD Current value to edit in keypad view - X -
_KEYPAD_DEST_
NAME

Name of the keypad's destination
variable name - X -

_KEYPAD_DEST_
TYPE

Type of the keypad's destination
variable type

- X -

_KEYPAD_OPEN Open keypad view - X -
_KEYPAD_SHIFT Used by keypad as caps-lock

functionality
- X -

_KEYPAD_TF_FO
CUS

Used to select the editable text field
after closing the keypad.

- X -

* X = supported, - = not supported

** not supported on all platforms

 

 

1.12 Filetransfer To PCD System

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

After having initialised all process points (PPOs) you should choose the command
'Build All' from 'File' menu to save the entire project. The 'Build All' command
copies all required files from the PG5 project sub directory 'Web' to the PG5
project sub directory 'html'.

Then, double-click on your *.wsp file inside your PG5 Project Manager (Web-

server Project file, created in PG5 by Menu File->New..->Web-server

Project) and you will see the following dialog:
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On the left side of the dialog you have all resources of your PG5 \html sub
directory. On the right side all resources which will be downloaded to the PLC are
listed. With the Button 'Add->' you can choose the files needed to be downloaded
to the PLC. It is important that the files <your_projectname>.itq,

<your_projectname>.tcr, '<your_projectname>.teq' and

'<your_projectname>.html' have to be added and downloaded to the PLC.

Finally, you press the button 'Generate' and close the dialog. Now, in your PG5
environment you can build your PG5 project and download it to your target PLC.

1.13 Updating Values From The Target

Each view contains a number of references to 'process points' (PPOs) of the PCD
System. In order to achieve a good performance in updating these values, the
painters do not ask the webserver to update each value separately. When the
applet is initializing, it collects all 'process points' that are referenced, makes a list
and sends this list to the server. This request informs the server, the values of
which have to be maintained for the current view. When this view needs to update
itself, it asks for the updated request list, which will be returned by the server. This
list contains all values that are actually needed. The user can choose between two
modes of requests:

Single Request Comprising All Views

Supported Platforms
- Java Applet

Only one request list is generated for the applet; it covers all views that are
included. The advantages are:

· Less files and therefore less overhead on the embedded file system.

· Instant initialization, because all process points are already known to the

server.

One Request For Each View

Supported Platforms
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- Java Applet
- MicroBrowser
- NanoBrowser

This option will make the applet generating a request for each view. The
advantages are:

If the applet contains many views using many variables the complete result set has
to be loaded from the target, also containing values that are not used by the actual
view. Posting a request for each view is therefore faster for complex HMIs.

This option is set in the HTML file containing the applet. The tag is called
'OrderPerView' and can be set in the 'Project Configuration' dialog box from the
menu 'Project'.

Update Period
 

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

The period in which the applet will be notified of changes of its process points can
be set by the user. The default operating mode of an applet is polling.

The period is set in the Project->Project Configurations... Dialog.

Actions On Condition

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

For certain properties of the painters you can indicate a condition, which has to be
true to make the property active. Examples are the 'Edit a Source' property in the
'Repaints' tab of the property dialog or the 'Border Advanced' tab, where you can
set the color of a painter depending of a condition. The format of these conditions
is always the same and is explained here.
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First you choose the type of the variable of which the condition shall depend.
Choose 'PPO' for real process points or 'CONTAINER' for HMI-internal variables.
Then indicate the name of the variable in the field 'Name'. Now you can set the
value in the field 'Value' to which the variable shall be compared to and the type of
comparison that can be:

!= not equal
< smaller than
<= smaller or equal than
== equal
>= greater or equal than
> equal than

 

 

1.14 Working With Error Codes

Supported Platforms
- Java Applet
- MicroBrowser

By using this 'error code' functionality, the user can define his own system
messages that are displayed as a function of a PPO error code number (e.g.
integer indicating an error code).
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In simple cases, an error message can be issued as a string from the PLC. The
drawbacks of these methods are the following:

· If the error strings shall be multilingual and the language will be changed on

the panel, this will be rather difficult to solve.

· String management on the PLC uses a lot of memory an is rather

complicated

The concept to be explained in this chapter allows the PLC to issue an error-code
(as an Integer). This error code will be used to determine the respective text from
the language resource that is currently selected.

A CSV language resource file is used to manage error codes and messages.

How To Make Use Of Error Codes

Set the source type of the painter that displays the error message to 'HTML Tag'.

To designate the respective error-string, the following syntax must be used:

ErrorCode_@PPO_MyPPOName@

ErrorCode_ Prefix for your error codes. This is free text.
MyPPOName PPO which contains the actual error code

The HTML-Tag: 'ErrorCode_@PPO_MyPPOName@' will be replaced at runtime by
HTML tags like 'ErrorCode_0', 'ErrorCode_1',.. 'ErrorCode_N.
If the PPO returns the value '1' the message that corresponds to 'ErrorCode_1' will
be shown.

Create a CSV file which includes the messages and the error codes:

Import the CSV file with the Project->Add To Project->File... menu

into your project.



32

Saia-Burgess Controls Ltd. S-Web Editor Help

Working With Error Codes

Choose Project-> Project configurations... activate the checkbox

'HTML Parameters in CSV file' and insert the filename of your error code CSV file
into the dropdown 'csv file'.

If you work with language files you can insert the error codes and messages into
every language file. Refer to the chapter 'Multilingual HMI's' for details.

 

 

1.15 Multilingual HMIs

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

In this chapter you will learn how to create multilingual HMIs. The user will be able
to switch the language by pressing a button in your HMI.

The concept is based on language resource files. For each language to be used, a
separate file must be added to the project. These files are in a CSV (comma
separated values) format and can be edited with any standard ASCII text editor
(read the section below 'Working With Unicode' if you want to use Unicode).

As source type for all language dependant texts you have to use the 'HTML TAG'
info-type, instead of e.g. 'STRING'.

The S-Web Editor is able to collect all 'HTML TAG' references and to generate a
CSV file including all 'HTML TAG' references. You can modify this automatically
generated CSV file and translate the 'HTML TAG' references into any language.

For example you can insert a button into your TEQ-view that changes the current
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language of your HMI during runtime with a simple button-action.

Define What Should Be Translated

Open the property window of the painter that should be translated and set the
DropDown list 'Type' to 'HTML-Tag'. Repeat this step for all painters that you want
to translate:

The string 'Bitte Passwort eingeben:' is now the 'HTML TAG' reference. This string
will be shown if no CSV-file is loaded during runtime. You can also enter a name
like 'PWTEXT1' and later you can create a CSV file which translates this into 'Bitte
Passwort eingeben:' and another one which translates it into 'Please enter your
password:'

Create One CSV File For Each language

Before the editor will create a CSV including the 'HTML TAG' references, you have
to define the filenames of your CSV files. Use the menu Project->Project

configurations... and type in the filenames into 'csv files (update)'.

 

Close the 'Project Configurations' dialogue and choose 'Generate HTML TAGS
CSV file' from the main toolbar:
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The editor will create the CSV files defined in the list 'csv files (update)'. After the
CSV file is created once, the 'Generate HTML TAGS CSV file' functionality updates
your existing CSV files.
If you define a new 'HTML TAG' reference, the editor will automatically add it (on
the first line) to your existing CSV files, if you use 'Generate HTML TAGS CSV
file'. The editor keeps all your translations that you have already made. If you
remove 'HTML TAG' references from your HMI, the editor will show a dialogue. You
have the choice between keep or remove old 'HTML TAG' references.

Open the CSV file you have created with the 'Generate HTML TAGS CSV file'
function in a text editor like Notepad. Insert the translation for each string and save
the file.

Syntax: HTML TAG reference; translation

Repeat this step for each of your language CSV files.

Define The Default Language CSV File

Use the menu Project->Project configurations... and go to the tab

'Project - Applet Advanced'.
Activate the option 'HTML Parameters in csv file', otherwise the runtime browser or
Java-applet searches the 'HTML TAG' references in the HTML file during runtime.

Insert the filename of your CSV language file, that you want to load at startup of
HMI :
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Create The Language Switch Button

The next step is to create a button for switching the HMI language at runtime:

Add a button painter into your main view

Open the painter's property window (double click on it).

Replace the text 'BUTTON' in the tab 'Repaints' with your own label:

Go to the tab 'Actions Set Variables' and activate checkbox 'Set a Variable' and
take the settings from following the screenshot:
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If you only have one CSV file you can't switch back to the 'original language'.
Therefore you have to create an additional CSV file:

Add a button painter into your view for the 'original language':

Open the painters property window (double click on it).

Go to the tap 'Repaints' and replace the text 'BUTTON' in the tab 'Repaints' with
your own label. Now go to the tab 'Actions Set Variables' and take the settings
from the following screenshot:

In the case described in this tutorial the language is german at startup. But the
user can switch the language to english by clicking the button 'English HMI
Version'.

Working With Unicode

The runtime Java-applet and MicroBrowser can display Unicode text.

Some fonts can not display all of the Unicode characters. It is recommended to
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use the font 'MS Sans Serif' which is a good choice for Unicode characters.

Don't edit your CSV file directly in the S-Web Editor, because the text window of
the S-Web Editor saves the CSV file in ASCII mode. You can use Notepad for
example to edit your CSV files (or any other text editor which allows you to save
files in Unicode format). In the 'Save As' dialogue in Notepad you can choose
'Unicode' in the DropDown 'Encoding'. Use the format 'Unicode Text' in MS Excel.

If you saved your CSV file in Unicode format and you have chosen a font in your
HMI which is able to display Unicode characters, the Unicode strings should be
displayed correctly. You needn't make additional settings in the S-Web Editor, if
you want to use Unicode.

 

 

1.16 Working With Macros

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

Macro objects can be used to manage often used painter combinations and their
configuration in a separate file (*.esm).

Since version 5.12 the editor creates macro files with *.esm file extension. The
editor is backward compatible with *.tlb files which is the old macro format.

Individual Solutions

Contact us if you need an individual painter. IniNet Solutions GmbH creates
customized Painters. These are delivered as macro objects and can be imported in
your project with the menu Library->Get object from library....

Build Your Own Macro
1. Create a new project named "myMacro" for example. (How to create a new

project is described in the chapter Getting Started)

2. Create a new Teq view with the Project->Add to Project->New

menu.

3. Insert and configure all painters that should be included in the macro object
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4. Select all Painters and click the group symbol in the bottom toolbar (see
chapter Group Functions for details)

5. Select the created painter group macro and create the macro file with the
menu Library->Insert object into library....

6. Choose a name for your macro (*.esm) and click "New_Save".

'Extra files' are additional files such as GIFs or TXT files. Click 'Add Files..' to
define them. If your macro don't needs any file resources you can leave
'Extra files' blank.

Inserting A Macro Object From The Library

With the menu function Library->Get object from library... you can

insert a library object into the active teq-view. After having inserted such an object
you normally should alter its references. This is done by double-clicking on it
which will pop up the group dialog. Select the Cross-reference tab and change the
references according to your needs.

You can ungroup the macro object to modify their position. Do this with the
ungroup symbol in the bottom toolbar:

Removing A Macro Object From The Library

With the menu function Library->Remove object from library.. you
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can remove and delete a library object. A file selection dialog will appear where you
can select the object(s) to be removed.

 

Modify An Existing Macro

The user might want to make modifications to an existing macro and then store
the modified macro under his own name. The problem about this is the fact that a
macro can consist of several files (images, PPO and container intitialisation,
macro dialog, etc.). Mainly when the user wants to modify a macro with an own
macro dialog (e.g. Tacho), this dialog must also be stored together with the
modified macro. Therefor, a macro cannot simply be copied and renamed, but
must be modified following the procedure as described:

Library->Modify macro from library..

Choose the macro you want to modify and apply the changes with the editor.
Please note that deleting core objects of certain macros might result in an inproper
operation. Changing size, layout, color and font properties or adding additional
objects is always possible without causing problems.

Library->Insert object into library..

Now save your modified macro under the new name. In the 'Save' dialog, you have
the possibility to add files to your macro that must be part of it (e.g. you have
added GIF images).

 

 

1.17 Multiple Views

Supported Platforms
- Java Applet
- MicroBrowser
- NanoBrowser

This section explains the user how to set up an HMI consisting of multiple views.
As we are developing for a networked environment, there are certain points that
must be considered for the design of such a solution in order to obtain the best
results in terms of performance and memory footprint.

In general, there are two different ways of how to change from one view to another:

Multiple Views In One Applet

The user requests one HTML page with the browser. This page (<your

projectname>.html) contains one applet (IMaster.jar), which references
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multiple views (stored as *.teq files). This is the fastest way to switch from one

view to another. All views and the corresponding applet code are loaded and
started when loading the HTML file <your projectname>.html into the browser. This
file is created from the project menu: 'Project->Generate HTML'.

Link To Another HTML File

It is also possible to link an applet view to another HTML view, which may contain
an applet, too. The disadvantage is, of course, that the browser needs a certain
time to load and initialise the new page and applet. Nevertheless, this feature can
be useful in certain cases like:

· links to help files (stored as HTML)

· links to HMI's from other webservers, to create 'virtually' one single HMI

· links to other applets or pages that are not created with S-Web Editor

 

 

1.18 Java Security Settings (For Microsoft VM)

This chapter is only relevant if you work with Microsoft VM.

Some times you need to do some operations that the Java security model doesn't
allow on your browser. For example if you need to send a file on the server (field
download or file upload). So, to force these kinds of operations you have to run
Java applet(s) outside the Java security sandbox, and allow all permissions for
applet downloaded from a trusted site.

How to configure the Internet Explorer browser in order to run the
Java applet(s) outside the Java security sandbox?
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1. Open the Internet options dialog in menu: Tools->Internet

Options... (or Alt T and O).

2. Choose tab "Security"

3. Double-click on the green "Trusted Sites" icon.

4. Deselect the checkbox "Require Server verification (https:) ...".

5. Press button "Sites..." and add the web site where the applet is located (for
example: MyPCName, or http://MyWebFrontServer), and click "OK".

6. Press the button "Custom Level…" (for trusted sites).
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7. Select on the list : Java->Java Permission->Custom

8. Now, you can press the press button "Java Custom Settings…"

9. Choose tab "Edit Permission"

10.And select on the list: Unsigned Content->Run Unsigned
Content->Enable
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11.Then press the "OK" and "Apply" buttons.

12.Restart the browser and try your applet again.

A green icon should be displayed on the status bar of the Internet Explorer browser
to indicate that you are displaying contents from a trusted site.

 

 

1.19 Signed Applets (For Sun VM)

This chapter is only relevant if you work with Sun VM.

The S-Web Editor works with signed applets. A dialog box like the following will
appear if you use Sun VM PlugIn:
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Accept the certificate with "Yes" or "Always". If you don't accept the certificate the
applet can't save files to local harddisk.

 

1.20 Working With MicroBrowser

This chapter describes MicroBrowser for Saia Terminals (uBTerminal).

uBTerminal containers

Container variables, available to the user, are included in the firmware of these
terminals.

Containers let the application program exchange information with the firmware. All
container variables have the prefix "uBT_".  Caution: case sensitive !!!

Container variables available for QVGA MB panels

Variable Description
uBT_Version Read current firmware version
uBT_IsConfigChange
d

Read 0 à Configuration unchanged

Read 1 à Configuration is changed
uBT_RestoreConfig Write 1 à Last saved configuration is restored
uBT_SaveConfig Write 1 à Current configuration is saved. When IPAddr,

SubNetMask or Default Gateway is changed, restart the
terminal.

uBT_EnableCache Read/Write 0 à Cache is disabled. Each file is loaded
every time.

Read/Write 1 à Cache is enabled. A loaded file will, if
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present, be taken from the cache. When switched off,
cache files are deleted. When switched on, cache files are
updated. 

uBT_DispType Read display type: Mono or Color
uBT_DispResolution Display resolution:

x à x axis [pixels]                                           example:
320

y à y axis [pixels]                                           example:
240

z à colour depth per pixel (bits per pixel)           example: 8
uBT_IsTSPresent TouchScreen present

Read 0 à  No

Read 1 à Yes
uBT_DoLcdCalib If TouchScreen present

Read/write 1 à a recalibration is executed.
uBT_LcdContrast Read/write: contrast value between  0 … 20
uBT_BackLight Read/write 0 àBacklight OFF

Read/write 1 àBacklight ON
uBT_BackLightTimeo
ut

Read/write timeout in minutes. If no user action is registered
during this time, the backlight is switched off.

If the value is 0 à the backlight is always active (switched
on).

uBT_TCPIPAddr Read/write TCP/IP address of terminal. Modification forces a
restart.

uBT_SubNetMask Read/write subnet mask of terminal. Modification forces a
restart.

uBT_DefaultGateway Read/write default gateway of terminal. Modification forces a
restart.

uBT_BuzzVol Read/write buzzer volume (0 … 20)
uBT_BuzzFreqIndex Read/write buzzer frequency (0 … 6)
uBT_EnableSIP Read/write SIP à Soft Input Panel

Write 0 à SIP is disabled. Virtual keyboards are disabled.

Write 1 à SIP is enabled. Virtual keyboards (alphapad.teq
and keypad.teq) are enabled.

Container variables available for VGA MB panels

auto-
update
Config
file

Container Type Defaul
t

Min
Value
Min
Length

Max Value
Max
Length

Description

yes uBT_AlarmFre
quency

ANSI Text
String

1000 125 8000Frequency setting of
the acoustic alarm
(Hz)
(Rounded to
125,250,500,1000,20
00,4000,8000)
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no uBT_AlarmSt
art

Decimal value
string

0 0 30000: 50
Sec

Start of acoustic
alarm, interval time
(mSec),
finished by any touch
on the screen.

yes uBT_AlarmVol
ume

Decimal value
string

10 0 20: 100% Acoustic alarm
volume setting

yes uBT_AutoRep
eat

Boolean value
string

0   SIP Key board:
Autorepeat on(1), off
(0)

yes uBT_Backligh
t

Boolean value
string

ON   Backlight on(1), off
(0)

At any touch of the
screen the back light
switches on again.
At back light on the
count down for the
back light timeout
restarts.

yes uBT_BackLig
htTimeout

Decimal value
string

15 0 5000Time (min) after
which the backlight
switches off.
At any touch of the
screen the back light
switches on and the
count down restarts.

yes uBT_BooterV
ersion

ANSI text
string

Curren
t
versio
n
string

0 8Firmware booter
version
Read only string

yes uBT_BuzzFre
q

ANSI text
string

500 125 8000Frequency setting of
the acoustic beep at
touch
(125,250,500,1000,2
000,4000,8000)

yes uBT_BuzzOn
Off

Boolean value
string

TRUE   Acoustic beep at
touch on (1)/off (0)

yes uBT_BuzzVol Decimal
enumerated
value string

0 :
OFF

0 20 : 100% Acoustic beep at
touch, volume setting

yes uBT_ConfigTy
pe

ANSI text
string

Curren
t
Config
Type

0 24Configuration Type
Read only string

yes uBT_ConfigVe
rsion

ANSI text
string

Curren
t
Config
Versio
n

0 4Configuration Version
Read only string

yes uBT_DefaultG
ateway

IP address
string

0x000
00000

  Gateway address for
remote (peer)
access, 0 not
configured
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no uBT_DispRes
olution

ANSI text
string

<Scre
enwidt
h>
<Scre
enheig
ht>
<Color
depth
>

0 16Resolution
information

Read only string

no uBT_DispTyp
e

ANSI text
string

Color 0 10Display type
information

Read only string
yes uBT_EnableC

ache
Boolean value
string

TRUE   Filecache use (1), 0
no filecache

yes uBT_EnableSI
P

Boolean value
string

TRUE   External SIP
Keyboard use (1), 0
no keyboard use

auto-
updat
e
Confi
g
file

Container Type DefaultMin Value
Min Length

Max
Value
Max
Length

Description

yes uBT_FirstPadNam
e

Decimal
enumerated
value string

0  alphapad.
teq

First used
entry pad file
index

no uBT_FlashStatus Decimal
value string

0 0 255M1 Flash 

status
20: Device
present,no file
system

21: Device
present,file
system OK

22: Device
present, error
at file system
creation

23: Device
present, busy
creating file
system

24: Device
present, busy
with flash
sector based
compression



48

Saia-Burgess Controls Ltd. S-Web Editor Help

Working With MicroBrowser

-1: Unknown
error

yes uBT_FocusBorder
Width

Decimal
value string

2 0 7Active object
focus frame
line width
(pixel): 1-5

yes uBT_InactivityPoll
Time

ANSI text
string

0 0 5Touch /
Keyboard
inactivaty
supervisory
selection (1),
at 0 off.
Used for a
switch to a
less frequent
touch /
keyboard entry
polling mode.

no uBT_IntFlashStat
us

Decimal
value string

0 0 255Internal Flash
status
20: Device
present,no file
system
21: Device
present,file
system OK
22: Device
present, error
at file system
creation
23: Device
present, busy
creating file
system
24: Device
present, busy
with flash
sector based
compression
-1: Unknown
error

yes uBT_IntroGraphic
Name

ANSI text
string

SaiaS
UGran
de.gif

0  Intro Graphic

yes uBT_IntroGraphic
XPos

Decimal
value string

100 0 639Intro Graphic
position

yes uBT_IntroGraphic
YPos

Decimal
value string

50 0 479Intro Graphic
position
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yes uBT_IntroText ANSI text
string

Welco
me

0 32 Intro text

yes uBT_IntroTextXPo
s

Decimal
value string

400 0 639Intro text
position

yes uBT_IntroTextYPo
s

Decimal
value string

300 0 479Intro text
position

yes uBT_TCPIPAddr IP address
string

0xAC1
703DF
:
192.16
8.12.9
0

  Own IP
Address

no uBT_IsTSPresent Decimal
value string

current
value

0 255Touch screen
detected (1), if
0 calibration at
start-up has /
will be
skipped.

no uBT_LastKeyEven
t

ANSI text
string

 0 32Last key event
code

no uBT_LastKeyEven
tUp

ANSI text
string

 0 32Last key up
event code

yes uBT_LcdContrast Decimal
value string

10 0 20: 100% Contrast /
Backlight
brightness
setting (0:20)

auto-
updat
e
Confi
g
file

Container Type Default Min
Value
Min
Lengt
h

Max
Value
Max
Lengt
h

Description

yes uBT_LocalFileSear
ch

Decimal
enumerated
value string

0:OFF 0 2Select local
filesearch mode
0: no local file use
1: use local files
before remote
2: use remote files
before local
The local search
order is fixed, in
order of use:
- Video cache
(image only)
- File cache (if
enabled)
- Internal Flash
- M1_Flash
- SD Card Flash if
used

no uBT_MACAddr ANSI text
string

 0 20Own MAC address

no uBT_MultiKeyValu
e

ANSI text
string

 0 6External SIP
Keyboard multi key
indication (1), 0 no
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actual multi key
active

yes uBT_SbusAddr Decimal
value string

10 0 253Own Sbus address

yes uBT_SecondsToIna
ctivity

ANSI text
string

0 0 5Touch / Keyboard
inactivaty
supervisory time
(Sec)
Used for a switch to
a less frequent
touch / keyboard
entry polling mode.

yes uBT_SerialNumber ANSI text
string

 0 12Serial Number

no uBT_Setup ANSI text
string

 0 10 

yes uBT_SubNetMask IP address
string

0xFFFF00
00

  Remote (Peer) IP
address mask

yes uBT_Version ANSI text
string

Current
version
string

0 32Firmware version
Read only string

 

Recognized Fonts of the MB-Panel PCD7.D4xx QVGA and VGA
resolution.

Default fonts available for QVGA MB panels

Font and font style Character Size

Arial 10, 12, 16

Arial Bold 14, 20

Courier New 10, 12, 16

Courier New Bold 14, 20

Tahoma 10, 12, 16

Tahoma Bold 14, 20

Default fonts available for VGA MB panels

Font and font style Character Size

Arial 10

12

16

20

24

36
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Arial Bold 14

20

24

36

Courier New 12

16

20

Courier New Bold 14

20

Tahoma 12

16

20

24

Tahoma Bold 14

20

24

 

If you do not pay attention at the text font and style you use in Web-Editor, you
take the risk to display undesired characters. Here below the little translation table
of some common Font and style.

Examples of Interpretation of wrong sizes or styles (QVGA).
· Arial 8, 20 à Arial 8 becomes Arial 10, Arial 20 become Arial Bold 20

· Arial Bold 12, 24 à Arial Bold 12 und 24 become Arial 12

· Courier New 8, 20 à Courier New 8 becomes Courier New 10, Courier New

20 becomes Courier New Bold 20
· Courier New Bold 10 à becomes Courier New 10

· Tahoma 8, 20 à Tahoma 8 becomes Tahoma 10, Tahoma 20 becomes

Tahoma Bold 20
· Tahoma Bold 16 à becomes Tahoma 16

· Arial 12 Italic à becomes Arial 12

· Arial 12 Bolld & Italic  à become Arial 12

· Lucida Calligraphy 12 à becomes Arial 12

Refer to the chapter 'WYSIWYG For Fonts' for more details

Programming Function keys for web panel with Fkeypads
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Place a button on the view and open the function keys tab.

Use the syntax: FKEY_1, FKEY_2 … FKEY_12 , …and ESC

The number of buttons depends on how many Fkeys you want to

use.

N.B.: case sensitive.

Example: With the comfort line MB panel, 12 function keys are available.

 

 

Do not use the “Hide Painter” command to hide the button.

A button hidden in this way will, in fact, be briefly visible on-screen when the page
is changing.

We advise you to place the buttons on an enlarged part of the background layer.

Further detail:

Use the advanced features of TEQ views.

One TEQ view can be made with three different layers. Each layer can be edited
separately by the user. At runtime, the three layers will merge into one view.
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What's the drill?

Create a background TEQ and enlarge it. Buttons corresponding to the Fkeys can
be placed in the enlarged area. In this way, they will be invisible on the screen
panel.

(Example with MB QVGA panels: standard size is 320 x 240, enlarged size is 320
x 280).

(Example with MB VGA panels: standard size is 640 x 480, enlarged size is 640x
560).

Further information

Documents References Comment www
User’s guide QVGA MB
panels

26/869 English

User’s guide VGA MB panels26/858 English (in the
packing)

Manual QVGA and VGA MB
panels

26/851 EN English www.sbc-support.
ch/

Manual QVGA and VGA MB
panels

26/851 DE German www.sbc-support.
ch/

Manual QVGA and VGA MB
panels

26/851 FR French www.sbc-support.
ch/
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1.21 Internet Explorer Settings (Only For Windows Vista)

This chapter is only relevant if you work with Internet Explorer on Windows Vista.

Internet Explorer 7 on Windows Vista has a new security function called 'Protected
Mode'. This protected mode runs the Java Applet with other security permissions.
The applet can only write to special temporary directories. Write operations to
other directories will also work but they will be redirected by the operating system
to other temporary directories. This can cause problems if you save a file within an
alarming HMI and you try to open the saved file with a macro that you start from
your local PC. You will not see the file in the second applet! To solve this problem
you can add the the URLs to your applets to the 'Trusted sites'.

The following screenshot shows a Java Applet that runs in the 'Protected Mode'

How To Configure The Internet Explorer Browser In Order To
Run The Java Applet Outside the 'Proteced Mode'?

1.Open the Internet options dialog in menu: Extras->Internetoptionen
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2.Choose 'Vertrauenswürdige Sites' in the tab 'Sicherheit' and click 'Sites'
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3.Deactivate the checkbox shown in the following screenshot that allows you

to add sites that begin with 'http' (by default trusted sites have to begin with
'https). Then type in the URL and click 'Hinzufügen'.
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Afterwards Internet Explorer deactivates the protected mode for the site you added
in the step before.

 

1.22 Working With NanoBrowser

NanoBrowser is optimised for eDisplay hardware with its limited amount of
memory. NanoBrowser implements almost all features known from embedded
MicroBrowser and is 100% compatible to the S-Web Editor. The workflow you are
familiar with has not changed. S-Web Editor checks several project parameters in
order to ensure that the HMI project fits to the eDisplay hardware and its memory
limitations (will be done during the 'Build All' process).

The Project Wizard And eDisplay Related Project Options

S-Web Editor reads information about the eDisplay hardware limitations from a
hardware profile that is built-in the project wizard.

S-Web Editor project wizard:
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According to the hardware profile the project wizard will make the project settings
that fit best to the eDisplay hardware (TEQ-View Size, zoom factor, colour…etc.).

S-Web Editor automatically sets the recommended project settings for the
eDisplay hardware.

Project's 'Build Advanced' settings activated by the project wizard:

NanoBrowser uses SpiderControl Font files in order to make the fonts that you use
in your HMI project available for the eDisplay. S-Web Editor reads your language
CSV files to figure out which Unicode character for what font type and size is
required for the HMI. S-WebEditor creates SpiderControl Font files that contain
exactly these Unicode characters and nothing else. This makes it possible to use
any Unicode character that is included in the respective TrueType you use in your
HMI (please see chapter Multilingual HMIs, Working With Unicode).
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Since version 5.14.05, the S-Web Editor is able to generate SpiderControl Font
files (have 'fnt' file extension) during the 'Build All' process. SpiderControl Font will
be downloaded and built with all other project files, so you don't need to do
anything special. If you choose the eDisplay hardware profile, the option that
causes the S-Web Editor to generate SpiderControl Font file is automatically
activated.

As you saw in the screenshot before, the S-Web Editor knows an option called
'Convert project's Gif to Bmp' in case of the eDisplay hardware. S-Web Editor
generates monochrome Bitmaps during the 'Build All' process if this option is
active. It is not recommended to deactivate this option, because eDisplay is not
able to display GIF images.

If you work with eDisplay, 'Generate/Update Scalable html files' is a useful S-Web
Editor feature. The MicroBrowser and Java-Applet runtime engine is able to scale
the HMI by a factor you define in the S-Web Editor project configurations (please
see chapter 'Editor Reference>Main Window').

NanoBrowser Macro Library

S-Web Editor comes with a MacroLibrary that was adapted for the small display
sizes and memory limitations of the eDisplay (please see chapter 'Macro Library
Index').
The macro format is the same for all platforms, if you consider the limitations of
display size and memory you are able to work with the same Macros you made for
other S-Web Editor HMI projects.

What you must know to create a user project?

User project start name

The default html user project start name is ‘estart.html’ .

Character Editing

Character Editing does work for PPO with STRING format

Maximum of PPOs, containers, painters … per project and per view

 number
Max PPO per project 100
Max Container per project 16
Max HTML Tag per project 1000
  
Max PPO per view 30
Max Container per view 16
Max HTML Tag per view 1000
Max Painter per view 20

See also /Web Editor/ SaiaDefaultSpiderHWProfile.shp

Navigation

Cause of the system of navigation (no touch screen) , one but only one 
“EventP_SetFocus_onGainFocus” macro is necessary in each teq view. You
advice to put this macro under a Jump action to another page.
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Default Fonts, Fonts and Font generator

In the project configuration, select Tahoma regular 8, 10 or 12 as default font !!!!

Default Fonts

The 3 default fonts and size are:

Tahoma regular 8 

Tahoma regular 10 

Tahoma regular 12

These fonts can be used in all case, for PPOs, Containers, Strings or html tags.

Other Fonts

Painters Format Tahoma
regular 8

Tahoma
regular

10

Tahoma
regular

12

Add*
font 1

Add*
font 2

Add*
font 3

Add*fo
nt 4

Button + Static
text

String x x x     

 PPO x x x     
 Containe

r
x x x     

 Html Tag x x x x x x x
Edit-box PPO x x x     
 Containe

r
x x x     

Multi-line label String x x x     
 Html Tag x x x x x x x
Macros         
Table control  x x x     
Drop down
PPO

 x x x     

Drop down html
tag

 x x x x x x x

         

* created with the font generator (Project configuration: Generate Spider Font Files)

Further information

Documents References Comment www
User’s guide eDisplay PCD7.
D300E

26/870 English  
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1.23 Advanced Functions

1.23.1 Macro Library Index

This chapter lists all official macros of the Macro Library ('MacroLib'). It offers a
short overview about their functionality and lists the references to other chapters for
detailed descriptions.

Some macros have more than one data source or destination. The table shows
only the source and destination that is important to understand the macro's
functionality. If you wish to have more information please see the respective
chapter (e.g. for trending or alarming).
Macros differ in their complexity. Some of the macros consist out of only of one
Painter others are more complex and consist out of many Painters. Every macro
has its own configuration dialogue so you don't have to care about the different
painters of a macro and how they interact.

\SaiaAlarmingMacro

Macro Name
Filename (add '_5_13_06.
esm') Description/Comment

Online Alarm List MacroAlarmingDefOnline Please see chapter 
Alarming Overview, Online
Alarm List

Offline Alarm History MacroAlarmingHisOffline Alarming Overview, Offline
Alarm History

Online Alarm History MacroAlarmingHisOnline Alarming Overview, Online
Alarm History

\SaiaAlarmingMacro\QVGAcolors

Macro Name
Filename (add '_5_13_01.
esm') Description/Comment

Online Alarm List
QVGA

Q_MacroAlarmingDefOnline Alarming Overview, Online
Alarm List

Online Alarm List
QVGA (Complete)

Q_MacroAlarmingDefOnlineCom
plet

Alarming Overview, Online
Alarm List

Online Alarm List
QVGA (Minimal)

Q_MacroAlarmingDefOnlineMini Alarming Overview, Online
Alarm List

Offline Alarm History
QVGA

Q_MacroAlarmingHisOffline Alarming Overview, Online
Alarm History

Online Alarm History
QVGA

Q_MacroAlarmingHisOnline Alarming Overview, Online
Alarm History

Online Alarm List
QVGA, FKEY
(Complete)

QFKEY_MacroAlarmingDefOnlin
eComplet

Alarming Overview, Online
Alarm List

Online Alarm List
QVGA, FKEY
(Minimal)

QFKEY_MacroAlarmingDefOnlin
eMini

Alarming Overview, Online
Alarm List

Offline Alarm History
QVGA, FKEY

QFKEY_MacroAlarmingHisOfflin
e

Alarming Overview, Offline
Alarm History

Online Alarm List
QVGA, FKEY

QFKEY_MacroAlarmingHisOnlin
e

Alarming Overview, Offline
Alarm History

\SaiaGeneral\MicroBrowser
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Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

Set Focus Event-
Painter (On Gain
Focus)

EventP_SetFocus_onGai
nFocus

X and Y
coordinat
es of the
Event-
Painter

@FOC
US

Use this macro to
define which painter
should be selected
first. Please see
chapter 
MicroBrowser
Specific Macros.

\SaiaGeneral\PasswordLogin

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

Password Dialog
Macro (User
Level)

PasswordDialog_UserLev
el

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

CONTA
INER,
PPO

Login with password
(no username
required)
Please see chapter 
Password Entry
Page

Password Dialog
Macro (User
Level)
Auto TEQ-Jump

PasswordDialog_UserLev
el_Auto

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

CONTA
INER,
PPO

Login with username
and password
Please see chapter 
Password Entry
Page

Logout Event-
Painter (On
Timeout)

EventP_Logout_onTimeou
t

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX,
CONTA
INER

Please see chapter 
Password Entry
Page

\SaiaGeneral\URLJumps

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

URL Jump Button
(On Mouse
Down)

ButonURLJump_onMouse
Down

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

URL Performs an URL
Jump On Mouse
Down. The user can
define the Button's
label as a STRING,
PPO, HTML TAG or
CONTAINER.

URL Jump Event-
Painter
(isEqual)

EventP_URLJump_isEqu
al

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

URL Performs a URL
Jump if X is equal to
Y. Where X and Y
can be STRING,
PPO, CONTAINER
or HTML TAG

URL Jump Event-
Painter
(On Timeout)

EventP_URLJump_onTim
eout

STRING,
PPO,
CONTAIN

URL Performs a URL
Jump after a specific
time of user inactivity
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\SaiaGeneral\ViewJumps

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

View Jump Event-
Painter
(isEqual)

EventP_ViewJump_isEqu
al

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX

Performs a TEQ-
View Jump if X is
equal to Y. Where X
and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

View Jump Event-
Painter
(On Timeout)

EventP_ViewJump_onTim
eout

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX

Performs a TEQ-
View Jump after a
specific time of user
inactivity

\SaiaGeneral\WriteSourceToDestination

Please refer to the chapter Write Source To Destination Macros for details

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

Write Source To
Destination
Event-Painter
(On Lost Focus)

EventP_writeSrc2Dst_onL
ost

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Lost Focus'

Write Source To
Destination
Event-Painter
(On Repaint)

EventP_writeSrc2Dst_on
Repaint

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Repaint'

Write Source To
Destination
Event-Painter
(On Gain Focus)

EventP_writeSrc2Dst_on
Gain

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Gain Focus'

Write Source To
Destination
Event-Painter
(isEquall)

EventP_writeSrc2Dst_isE
qual

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data if X
is equal to Y. Where
X and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

\SaiaGeneral
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Macro Name Filename Data Source
Data
Destination

Description/
Comment

DropDown List DropDownList_5_13_
40.esm

STRING,
HTML TAG

PPO,
CONTAINE
R

Implements a
DropDown that
reads the list of
items from a
STRING or HTML
TAG and uses a
PPO or
CONTAINER to
point to the
current item

Animated GIF AnimatedGif_5_13_0
1.esm

FILE - Implements an
animated GIF
functionality.
Refer to the
chapter Animated
GIF Macro

Blinker Blinker_5_10_00.tlb @BLINKCO
(CONTAINER
)

- Blinker

Tacho Tacho_5_13_40.esm STRING,
PPO,
CONTAINER,
HTML TAG

- Implements a
tachometer

Table Control
Editable PPO
Page Jump

TableControl_Editabl
ePPO_PageJump_5_
10_00.tlb

PPO,
CONTAINER

PPO Table control
consisting of
separate edit-
fields

Editable Multi-
Line

EditableMultiline CONTAINER,
PPO

CONTAINE
R, PPO

Macro to edit text
over several lines.
During runtime:
Press Ctrl
+ENTER to force
a line break.

\SaiaHDLogTrendMacro

Macro Name
Filename (add '_5_14_03.
esm') Description/Comment

HDLog Trend Macro
(Complete)

RemoteOffSavedTrdComplete Please see chapter HDLog
Trend Macros

HDLog Trend Macro
(Minimal)

RemoteOffSavedTrdMini Please see chapter HDLog
Trend Macros

\SaiaTrendMacro

Please see chapter Trend Macros Introduction to understand the concepts of
Online, Offline and Saved Trending.

Macro Name
Filename (add '__5_13_01.
esm') Description/Comment

Offline Saved Trend
(Complete)

OfflineSavedTrendComplete Please see chapter Offline
Saved Trend Complete

Offline Saved Trend
(Minimal)

OfflineSavedTrendMinimal Offline Saved Trend
Minimal

Offline Saved Trend OfflineSavedTrendScalable Offline Saved Trend
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(Scalable) Complete
Offline Trend
(Complete)

OfflineTrendComplete Offline Trend Complete

Offline Trend (Minimal) OfflineTrendMinimal Offline Trend Minimal
Offline Trend Load X
Min Definition
(Minimal)

OfflineTrendMinimalOnLoadXMin
Def

Offline Trend Minimal

Offline Trend
(Scalable)

OfflineTrendScalable_5_13_01.
esm

Offline Trend Scalable

Offline Trend Load X
Min Definition
(Scalable)

OfflineTrendScalableOnLoadXMin
Def

Offline Trend Scalable

Online Trend
(Complete)

OnlineTrendComplete Online Trend Complete

Online Trend (Minimal)OnlineTrendMinimal Online Trend Minimal
Online Trend
(Scalable)

OnlineTrendScalable Online Trend Scalable

\SaiaTrendMacro\QVGAcolors

Macro Name
Filename (add '_5_13_01.
esm') Description/Comment

Offline Saved Trend
QVGA (Minimal)

Q_OfflineTrendMinimal Offline Trend Minimal

Offline Saved Trend
QVGA, Save To File
(Minimal)

Q_OfflineTrendMinimal_Save2Fil
e

Offline Trend Minimal

 
NanoBrowser Macro Library (eDisplay)
 

Macro Name

Filename
(add
'_5_14_03.
esm') Data Source

Data
Destination

Description/
Comment

NanoBrowser
Blinker

eD_Blinker @BLINKCO
(CONTAINER)

- Blinker macro

NanoBrowser
URL Jump
Button (On
Mouse Down)

eD_ButonUR
LJump_onM
ouseDown

STRING, PPO,
CONTAINER,
HTML TAG

URL Performs an URL
Jump On Mouse
Down. The user
can define the
Button's label as
a STRING, PPO,
HTML TAG or
CONTAINER.

NanoBrowser
DropDown List

eD_DropDow
nList

STRING, HTML
TAG

PPO,
CONTAINER

Implements a
DropDown that
reads the list of
items from a
STRING or HTML
TAG and uses a
PPO or
CONTAINER to
point to the
current item

NanoBrowser
Logout Event-

eD_EventP_
Logout_onTi

STRING, PPO,
CONTAINER,

TEQ INDEX,
CONTAINER

Please see
chapter Password
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Painter (On
Timeout)

meout HTML TAG Entry Page

NanoBrowser
URL Jump
Event-Painter
(isEqual)

eD_EventP_
URLJump_is
Equal

STRING, PPO,
CONTAINER,
HTML TAG

URL Performs a URL
Jump if X is equal
to Y. Where X
and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

NanoBrowser
URL Jump
Event-Painter
(On Timeout)

eD_EventP_
URLJump_o
nTimeout

STRING, PPO,
CONTAINER

URL Performs a TEQ-
View Jump after a
specific time of
user inactivity

NanoBrowser
View Jump
Event-Painter
(isEqual)

eD_EventP_
ViewJump_is
Equal

STRING, PPO,
CONTAINER,
HTML TAG

TEQ INDEX Performs a TEQ-
View Jump if X is
equal to Y. Where
X and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

NanoBrowser
View Jump
Event-Painter
(On Timeout)

eD_EventP_
ViewJump_o
nTimeout

STRING, PPO,
CONTAINER,
HTML TAG

TEQ INDEX Performs a TEQ-
View Jump after a
specific time of
user inactivity

NanoBrowser
Write Source To
Destination
Event-Painter
(isEquall)

eD_EventP_
writeSrc2Dst
_isEqual

STRING, PPO,
CONTAINER,
HTML TAG

PPO,
CONTAINER

Writes the source
data to the
destination data if
X is equal to Y.
Where X and Y
can be STRING,
PPO,
CONTAINER or
HTML TAG

NanoBrowser
Write Source To
Destination
Event-Painter
(On Gain
Focus)

eD_EventP_
writeSrc2Dst
_onGain

STRING, PPO,
CONTAINER,
HTML TAG

PPO,
CONTAINER

Writes the source
data to the
destination data
'On Gain Focus'

NanoBrowser
Write Source To
Destination
Event-Painter
(On Lost Focus)

eD_EventP_
writeSrc2Dst
_onLost

STRING, PPO,
CONTAINER,
HTML TAG

PPO,
CONTAINER

Writes the source
data to the
destination data
'On Lost Focus'

NanoBrowser
Write Source To
Destination
Event-Painter
(On Repaint)

eD_EventP_
writeSrc2Dst
_onRepaint

STRING, PPO,
CONTAINER,
HTML TAG

PPO,
CONTAINER

Writes the source
data to the
destination data
'On Repaint'

NanoBrowser
Password
Dialog Macro
(User Level)

eD_Passwor
dDialog_Use
rLevel

STRING, PPO,
CONTAINER,
HTML TAG

CONTAINER,
PPO

Login with
password (no
username
required)
Please see
chapter Password
Entry Page

NanoBrowser eD_TableCo PPO, PPO Table control
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Table Control
Editable PPO
Page Jump

ntrol_Editabl
ePPO_Page
Jump

CONTAINER consisting of
separate edit-
fields

Set Focus
Event-Painter
(On Gain
Focus)

EventP_SetF
ocus_onGain
Focus

X and Y
coordinates of
the Event-Painter

@FOCUS Use this macro to
define which
painter should be
selected first.
Please see
chapter 
MicroBrowser
Specific Macros.

 

What is a 'Data Source' or 'Data Destination'?
most of the macros write a source to a destination to perform the required action.
The following data types (also called infos) are possible: STRING, PPO,
CONTAINER, HTML TAG, URL, FILE, TEQ INDEX

What is an Event-Panter (EventP)?
An Event-Painter is an invisible Painter object that is able to perform actions
depending on specific events and defined conditions.

The following events are possible:

Name When do they occur?
On Gain
Focus:

User jumps on a TEQ-View

On Lost
Focus:

User leaves a TEQ-View

On
Repaint:

Every period

On
Mouse
Down:

Mouse click

Conditions:

Name When are they true?
On
Timeout:

Value of @MB_InactivityCounter is higher than X

Is Equal If X is equal to Y
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1.23.2 General Purpose

1.23.2.1 Animated GIF Macro

In the S-Web Editor you can't import animated GIFs directly. There are several
different animated GIF formats which are incompatible to each other.
The S-Web Editor implements the animated GIF functionality as a macro object.
The idea of this macro is, that you have to save your animation as separate static
GIF files.
The index in the filenames of these GIF files defines the display order of the
pictures during the animation.
Define the gif filenames in a way that they are all extended with the appropriate
index. This could look like this:
myAni0.gif
myAni1.gif
...
myAniN.gif

(replace the 'N' with the last number)

During runtime the macro will loop through all those gifs in the right indexed order
at each period.
The animation jumps back to gif '0' when the last index is reached.

Name: AnimatedGif_[EDITOR_VERSION].tlb

What the user has to do
1. Import the macro

2. Double click and choose the 'Cross Ref' tab

3. The following window appears:

CONTAINER
"AnimatedIndexCO"

Contains the actual gif filename index during runtime.
You have to change the Container name, if you have
more than one macro-object in your HMI. Extend for
example the container name with an additional number:
AnimatedIndexCO
AnimatedIndexCO1
...
AnimatedIndexCON
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Be sure that you don't use the macro-object more than
once with the same index Container name in your HMI.

CONTAINER
"AUTOINCRCO"

Don't modify this container name

STRING "%" Don't modify this string
STRING
"NbrImages"

Replace this string with the number of animation's
images. If you have the following images for example:
myAni0.gif
myAni1.gif
...
myAni4.gif

You have to replace the 'NbrImages' string with
'5' (because index starts at '0').

FILE
"Animated@CO_Ani
matedIndexCo@.gif"

The Animated GIF macro determines the image's
filename with 'Container Offset' (see chapter Container
Offset for details).
Please modify the first part of this string now
('Animated').
In the case of the example with 'myAni0.gif' the string
should look like this:
FILE "myAni@CO_AnimatedIndexCo@.gif"

If you modified the name of the Container
'AnimatedIndexCO' you have to update the Container
name in this string too.
Replace the string between the '@' signs with the new
name of your index container.

4. Confirm your modifications and close the 'Cross Ref' window. Your animated
gif should work now in the browser.

1.23.2.2 Write Source To Destination

The macros described in this chapter can be used to write a source to a
destination. The source is a static string, PPO variable, Container variable or HTML
Tag.
The destination is always a PPO or Container variable. The user will not see the
macro during the runtime, because it is built with Event-Painters (only visible in the
S-Web Editor).

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

Write Source To
Destination
Event-Painter
(On Lost Focus)

EventP_writeSrc2Dst_onL
ost

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Lost Focus'

Write Source To
Destination
Event-Painter
(On Repaint)

EventP_writeSrc2Dst_on
Repaint

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Repaint'
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Write Source To
Destination
Event-Painter
(On Gain Focus)

EventP_writeSrc2Dst_on
Gain

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data 'On
Gain Focus'

Write Source To
Destination
Event-Painter
(isEquall)

EventP_writeSrc2Dst_isE
qual

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

PPO,
CONTA
INER

Writes the source
data to the
destination data if X
is equal to Y. Where
X and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

What is an Event-Panter (EventP)?
An Event-Painter is an invisible Painter object that is able to perform actions
depending on specific events and defined conditions.

The following events are possible:

 
Name When do they occur?
On Gain
Focus:

User jumps on a TEQ-View

On Lost
Focus:

User leaves a TEQ-View

On
Repaint:

Every period

 
What the user has to do

S-Web Editor provides a simple dialogue to configure the Event-Painter macros.

Double click the imported macro in order to open the macro configuration dialogue:
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If you wish to read more about how to use macros, please refer to the chapter 
Working With Macros.

1.23.2.3 Password Login Macros

S-Web Editor offers several macros to implement a password entry page for your
HMI. The approach works with a Container variable that holds the current user
level. If the HMI user enters a correct password the macro sets the user level to
the corresponding value. You are able to define up to four different user levels with
a separate password. Dependant on this user level you can restrict the access to
your HMI by hiding or disabling Painter objects or groups.
With an additional macro it is possible to check if the user typed in a correct user
name (please see list below).

Macro Name

Filename
(add
'_5_13_40.
esm') Description

Password Dialog Macro
(User Level)

PasswordDialo
g_UserLevel

Basic password entry page macro that
works with four user levels and
password

Password Dialog Auto TEQ
Jump Macro (User Level,
Username and Password)

PasswordDialo
g_UserLevel_A
uto

Password entry page that provides an
additional username check and an
automatic TEQ-View jump if the user
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typed in a correct username and
password

Logout Event-Painter (On
Timeout)

EventP_Logout
_onTimeout

Performs a logout after a certain time
of inactivity (inactivity means no user
interaction). The logout mechanism
resets the user level to '0' and performs
a TEQ-View Jump to a logout TEQ-
View

What the user has to do

S-Web Editor provides a simple dialogue to configure macros.

Double click the imported macro in order to open the macro configuration dialogue.

If you wish to read more about how to use macros, please refer to the chapter 
Working With Macros.

 

 

 

 

 

 

 

1.23.2.4 DropDown List

A DropDown List is an object which opens upon selection and offers a choice of
different elements. The user selects one of them, and the selection closes again,
showing nothing but the selected element.

The DropDown List object is linked to two data-sources:
A PPO or Container variable where the index (as an integer) of the chosen element
is read and written to. 'item1' is linked to index 0, 'item 2' to index 1, etc.
A list containing the text items (item1, item2, ..) which can be modified at will by
the user. There are two possible sources for an item list.
The listed can either be defined as a string using the object's dialog, or as a HTML-
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tag, where the item-string can be defined in a language dependant csv-file (see
also chapter Multilingual HMI's).

Macro Name Filename Data Source Data Destination
DropDown
List

DropDownList_5_13_40.
esm

STRING, HTML
TAG

PPO, CONTAINER

What the user has to do

The item-list must be entered as a single string using '\n' (two characters) as a
separator.

Example:
None\nMove1\nMove2\nMove3\nMove4\nMove5\nMove6

Previous macro versions used the character '¢' (ASCII 162) as separator. IMaster
Java-Applet und MicroBrowser are backward compatible to this separator.

S-Web Editor provides a simple dialogue to configure the Event-Painter macros.
Double click the imported macro in order to open the macro configuration dialogue.

If you wish to read more about how to use macros, please refer to the chapter 
Working With Macros.

 

1.23.2.5 Automatical TEQ/URL Jump

Automatical TEQ/URL Jump macros can be used to force a TEQ-Jump or URL-
Jump if a certain condition is true or a event occurs. The user will not see the
macro during the runtime, because it is built with Event-Painters (only visible in the
S-Web Editor).

The following events are possible:

Name When do they occur?
On Gain
Focus:

User jumps on a TEQ-View

On Lost
Focus:

User leaves a TEQ-View

On
Repaint:

Every period

Conditions:

Name When are they true?
Is Equal If X is equal to Y

\SaiaGeneral\URLJumps

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin

Description/
Comment
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ation
URL Jump Event-
Painter (On
Repaint)

EventP_URLJump_onRep
aint

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

URL Performs an URL
Jump On Repaint.

URL Jump Event-
Painter
(isEqual)

EventP_URLJump_isEqu
al

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

URL Performs a URL
Jump if X is equal to
Y. Where X and Y
can be STRING,
PPO, CONTAINER
or HTML TAG

URL Jump Event-
Painter
(On Timeout)

EventP_URLJump_onTim
eout

STRING,
PPO,
CONTAIN
ER

URL Performs a URL
Jump after a specific
time of user inactivity

\SaiaGeneral\ViewJumps

Macro Name
Filename (add
'_5_13_40.esm')

Data
Source

Data
Destin
ation

Description/
Comment

View Jump Event-
Painter (On
Repaint)

EventP_ViewJump_onRe
paint

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX

Performs a TEQ-
View Jump On
Repaint.

View Jump Event-
Painter
(isEqual)

EventP_ViewJump_isEqu
al

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX

Performs a TEQ-
View Jump if X is
equal to Y. Where X
and Y can be
STRING, PPO,
CONTAINER or
HTML TAG

View Jump Event-
Painter
(On Timeout)

EventP_ViewJump_onTim
eout

STRING,
PPO,
CONTAIN
ER,
HTML
TAG

TEQ
INDEX

Performs a TEQ-
View Jump after a
specific time of user
inactivity

 
What the user has to do

S-Web Editor provides a simple dialogue to configure the Event-Painter macros.
Double click the imported macro in order to open the macro configuration dialogue.

If you wish to read more about how to use macros, please refer to the chapter 
Working With Macros.
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1.23.2.6 Table Control/Spread Sheet

This macro can be used like a table control consisting of separate edit-fields, each
of them pointing to a PPO. The PPO can be read and written. The table can be
scrolled page-wise (page up and page down) using the two buttons showing
arrows. Line-wise scrolling is not supported.
The table control is based on an indexed addressing mechanism, where the
address-offset can be modified dynamically with an up and down button. The offset
is stored in a container variable called 'listOff'.
The table is organized in rows, where each row represents an array of a certain
PPO base address. The container offset is added to the base offset. The base
offset is defined for each object fields PPO reference.
The table control can be modified in every way, e.g. rows and columns can be
added or deleted. The existing rows show an addressing scheme for sample
PPO's. To modify these PPO's, it is recommended to select all objects of a row
and to use the Cross Ref function. PPO names can be updated separately. A
more efficient way is to use the 'Find/Replace' function which can be found on the
'Cross Ref' tab. This function performs a substring replace on all selected objects.
E.g. if you want to exchange the row using 'PDP,,R100x,d' PPO name by a
symbolic array named myVar[x], do the following:

1. select the complete row and open the 'Cross Ref' dialog (right mouse button
menu or bottom tool box). Select the 'Cross Ref' tab.

2. Press the 'Find/Replace' button. Enter 'PDP,,R100' in the 'Find' field and
'myVar[' in the 'Replace' field. Press 'OK'. Then enter ',d' in the 'Find' field
and ']' in the 'Replace' field. Press 'OK'.

If you use more than one instance of this object in one project, make sure to
exchange the container variable name to a unique identifier for each table,
otherwise the table offset of all your tables will be synchronized.

Name: TableControl_EditablePPO_PageJump_[EDITOR_VERSION].tlb

What the user has to do
1. Import the macro

2. Ungroup the macro

3. Modify rows and columns
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4. In the page-up/down buttons: modify the increment/decrement step
according to the number of rows

5. In the page-down button: modify the 'hide/disable' condition to hide the
button, if the last page is reached, according to the number of elements that
you have defined in your arrays.

6. Delete the comment section

1.23.2.7 Blinker

The blinker macro toggles between two colors every period. You can define these
colors. Make a double click on the inserted macro and click the entry 'Rectangle
Repaint'. In the tab 'Border Advanced' you can define the two colors.

Name: Blinker_[EDITOR_VERSION].tlb

1.23.2.8 MicroBrowser Specific Macros

This chapter describes macros which are only supported in the MicroBrowser
client. This means they write or read from special MicroBrowser Container
variables.
MicroBrowser specific macros can be found in the macro library directory
'SaiaGeneral/MicroBrowser'.

Set Focus On Gain Focus

Place this macro in front of the Painter you want to have selected first when the
TEQ view is loaded (e.g. useful if you have a 'Next Page' Button).

MicroBrowser reads the coordinates of the macro and selects the object with the
closest coordinates.

SaiaGeneral\MicroBrowser

Macro Name Filename (add '_5_13_40.esm')
Data
Source

Data
Destinati
on

Set Focus Event-
Painter (On Gain

EventP_SetFocus_onGainFocus X and Y
coordinates

@FOCUS
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Focus) of the Event-
Painter

What the user has to do
1. Import the macro

2. Place the macro in front or back of the painter that should be selected first.

 

 

 

 

 

 

 

 

 

 

 

 

1.23.3 Trend Macros

1.23.3.1 Introduction

Introduction

What kind of trend-objects can be used?

The libraries (Offline, Offline Saved, Online) offer three different types of trending
macros. Every macro varies in terms of complexity and functionality.

Client-Sided Trending

The easiest way to record a trend is to record a PPO in the browser. The value is
drawn by the Java-Applet or MicroBrowser to a trend curve. If the user leaves the
trend HMI, the value will not be recorded any longer. This trend type is called '
Online Trend' which is described in the respective chapters later on. But this type
of trending is only of limited use.

PCD RAM Based Trending (for small data amount)

Offline trends refer to records that were made by the PLC. The user can access
the PLC whenever he likes and can watch the trend history which was recorded by
the PLC. Access to PLC's which record such trends can very often be of limited
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bandwidth. The user therefore has the possibility to select the range of the
recording in order to load only a part of the data stored on the PLC. All data that is
loaded to the client is then stored locally inside the client. The user can navigate
and zoom inside the uploaded data at will. It is possible to upload additional data
(if only a fraction had been loaded before) at any time. Data which is already stored
in the client will not be lost.

The PCD holds the data of Offline Trend macros in RAM. If you use these macros
you are very limited in how much trending data you can manage. If you wish to
record trending data over a longer time, it is better to use the macros described in
the next section.

PCD Flash Based Trending (for large data amount)

HDLog Trend Macros are able to manage large amount of trending data. This is
possible, because the new approach is to store the trending data on the flash
memory of the PCD and not in RAM as Offline Trend Macros. Please refer to
chapter 'PCD Flash Based trending' for more details.

Viewing Trend Logfiles

It is possible to save the uploaded data to a local file (on the client side). The
recordings can be saved on a harddisk. These files are stored in a CSV format and
can be analysed in external programs (like Excel, etc.). It is also possible to
reload these files with the browser. The user might want to analyse the saved trend
curves in a situation when no online connection to a PLC is active. Therefore, a
group of additional macro-functions is offered for this purpose.

These macros are called 'Offline Saved Trend'. An HMI for offline analysis may be
loaded directly from the hard-disk of the PC. No download of the S-Web HMI to a
PLC is necessary, because no connection to PPO's is required. Like this, a user
can have a local application on a PC that runs autonomously without any network
connections.

Maximal Number Of Trends Per Macro

For Offline Trend the configuration of a trend macro is stored in a string that has a
maximum size of 2 KB.
The size of a trend curve is 90 bytes + trend name length.
For example if your trend names have about 10 characters length:
2000 bytes / (90 byte + 10 byte) = 20 trends

For HDLog Trend macros the maximum number of trend curves is 10.

 

 

 

1.23.3.2 PCD Flash Based Trending

HDLog Trend Macros are able to manage a large amount of trending data. This is
possible, because the new approach is to store the trending data on the flash
memory of the PCD and not in RAM as Offline Trend Macros.
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In comparison to Offline Trend macros there is also a difference in how the browser
client communicates with the PCD: In case of HDLog Trend macros the trending
data is stored and organised in files. This means the browser client will get files
with trending data from the PCD; So HDLog macros don't have to use CGI calls in
order to receive the trending data from the PCD.

How To Work With HDLog Trend Macros In The Editor

First of all you have to define the HDLog HDF files in the project's configuration
window:

Use the menu Project->Project configurations... and add your

HDLog files by clicking 'Add' like shown in the screenshot below.

(PG5 creates these HDF files, please refer to the PG5 manual)

Confirm with OK and now import the following macro:

\SaiaHDLogTrendMacro
Macro Name Filename (add '_5_13_40.esm')
HDLog Trend Macro (Complete) RemoteOffSavedTrdComplete

S-Web Editor provides a simple dialogue to configure the HDLog Trend macro.
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Double click the imported macro in order to open the macro configuration dialogue:

Displa
yed
Time

Defines the displayed time range

Stored
Time

Maximum amount of data that the client holds in RAM

Show
Grid

Show grid during runtime?

Autom
atic
Y...

Show Automatic Y Axec description?

Add Adds a trend curve
Insert Inserts a trend curve above the line that is currently selected
Remov
e

Removes the selected trend curve

If you click 'Add' or 'Insert' you see a list of all available curves provided by the
defined HDLog files:
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If you wish to read more about how to use macros, please refer to the chapter 
Working With Macros.

How To Use The HDLog Trend Macros At Runtime

The handling of the HDLog Trend Macros is simple and very similar to other trend
macros.

· You can make use of the Zoom and Scroll buttons in order to adapt the

displayed time range to your own needs. This may cause the client loads
new trending files from the PCD

· Clear Logs will erase the trending data, that the clients currently holds in

RAM (not on PCD's Flash).
· Save Logs to file: Use this button to save the currently loaded trending

data into a file on your local harddisk.
· Stop Load Data: Abort the loading of new trending files (usually trending

data is loaded from more than one file)

· Reload Last: Reloads the latest Trend file from the PCD Target

If the TEQ-View with the HDLog Trend macro opens, it will show as default the
time range of the last 10 hours (see Configuration Dialogue of the macro 'Displayed
Time [s]') as shown in the screenshot below:
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Use Zoom and Scroll buttons to adapt the shown time range. If you click the
coloured button a dialogue to change the trend curves colour will appear

 

Variations Of HDLog Trend Macros

Additionally, two proposals for both a very simple as well as a modifiable HDLog
trend macro have been added to the library.

Macro Name Filename (add '_5_14_23.esm')
HDLog Trend Macro (Scalable) RemoteOffSavedTrdScalable
HDLog Trend Macro (Minimal) RemoteOffSavedTrdMini

The scalable HDLog shows all ten lines of the configurable curves, so no scrolling
is required during runtime. If the user wants to configure less than ten curves, he
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can delete the unused lines.

The minimal macro has no runtime options to modify the trends. Every trend that
was defined with the editor will be loaded and displayed.

Stop Loading During Runtime

After the Macro has started to load the HDLog files from the PLC's flash, this might
take some considerable time to upload. Using the 'Stop Loading' button allows to
stop the upload.

 

1.23.3.3 PCD RAM Based Trending

This chapter gives you an overview about the offline trend macros. The differences
in handling for every macro is described in a separate chapter:

1. Offline Trend Complete

2. Offline Trend Minimal

3. Offline Trend Scalable

The Offline Trend Painter is a macro object which can be imported with the menu 
Library->Get object from library. This macro can be used to load

historical logged data from a Saia®PCD and display the data in graphical trend
curves. The PCD records the data using the HDLog FBox library. The HDLog
library is provided together with the Web-Editor and can be installed or copied into
the PG5&/Libs/usr FBox directory. The FBoxes must be used in a PG5 Fupla
project to record historical data. The recording settings are done in the FBox
adjust settings. For details refer to the Online Help of the FBox. Before designing
an offline trend in the web-editor a corresponding PG5 fupla project with the HDLog
FBoxes must be created and compiled. The PG5 symbols of the trending data
blocks are then available in the web-editor.

How To Work With Offline Trend Macros In The Editor

The trend macros consist of several painter objects which are grouped to one
macro-object. The user can ungroup the macro and access each element
separately. Most of these objects are not editable with the standard dialog of this
editor.

Anyway, all references inside these objects can be accessed and modified by
using the CrossRef function. As the trending macro contains a rather complex
functionality, it is not recommended to modify the references, but the user can
easily move or resize the objects of this macro.

The objects of the trend-macro communicate with each other via container
variables. The names of these containers will be extended by a unique code at the
moment when the user imports the macro. This is necessary to generate a unique
instance of the trend macro object. The names to be generated may have the form
e.g. "@MACRO_NewYMax.122345676788990". The user should not modify such
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values, as they are generated and modified automatically. If you export a modified
macro, the editor will automatically remove these indexes. So, you don't have to
care about it.

Insert An Offline Trend Into Your View
1. Create a new Teq view in the project you want to insert the Online Trend

Painter. Do this with Project-> Add to Project-> New.

(How to create a new project is described in the chapter Getting Started)

2. Insert the Online Trend Macro object into your teq view choose Library->
Get object from library

3. Change to your "MacroLib" directory. Select the file name of the offline trend
macro you want to insert:

Offline Trend Complete: "OfflineTrendComplete.tlb"

Offline Trend Minimal: "OfflineTrendMinimal.tlb"

Offline Trend Scalable: "OfflineTrendScalable.tlb"
The inserted Offline Trend Complete:

Offline Trend Minimal:
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Offline Trend Scalable:

Configure The Macro

The following section explains how to configure curves in offline trend macros
painter (it is basically the same in all offline macro variants):

1. Double-click on the inserted object to open the Cross Ref dialog

2. Click on the entry ".._Macro Offline Trend_Repaint:
_@MACROOFTActive...." in the Advanced Select tab. Alternatively, it is

also possible to ungroup the trend-macro and to double click on the painter
object which will display the trend curves (uppermost object).
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3. Go to the tab Macro Offline Trend
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4. Click "Select" next to the "Base PPO Name" text field to choose the PG5
symbol (e.g. Trend_Base_DB) which indicates the base address of the data
structure defined by the HDLog Init FBox. If any other PPO is used the
result will fail. The basic data block contains basic information (e.g. data
base size, number of trends, &) for all trend curves of the HDLog data base.
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5. Confirm your choice with "OK"

6. Now, the trend curves to be displayed shall be selected. Click "Select" next
to the "PPO Name" text field.

7. Select a PPO and click "OK". This variable MUST contain a trend data
structure which is defined by the trend FB. If the user indicates any other
PPO's, the result will fail. The trend PPO contains information and data of
one trend curve.

8. Define the curve color and the Y-Min and Max value

9. Click "Add" to add your curve define to the trend

10.Repeat the steps 9-12 for all curves you want to add to the trend.
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If you want to change a curve definition, click on the entry in the list do your
modifications and confirm with "Update" .

Show Grid (Optional)

This option will add a 10x10 pixel grid to your trend. You will find this checkbox in
the Macro Offline Trend tab:

1. Double-click on the inserted macro to open the Cross Ref dialog

2. Click on the entry ".._Macro Offline Trend_Repaint:
_@MACROOFTActive...." in the Advanced Select tab

3. Activate the checkbox "Show Grid".

4. Now leave the dialog Macro Offline Trend and Cross Ref with

"OK".

Automatic Y axes description (Optional)

"Automatic Y axes description" will add a description for each curve to the y-axis
at runtime. The description shows you a scale from the defined "Y Min" to "Y
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Max".
If you have 2 curves for example, one description will be added to the left side and
one to the right (as shown in the picture below).
The color of the scale will be the same as the color of the curve which belongs to
it.

The automatic description at runtime:

1. Double-click on the inserted macro to open the Cross Ref dialog

2. Click on the entry ".._Macro Offlien Trend_Repaint:
_@MACROOFTActive...." in the Advanced Select tab

3. Activate the checkbox "Automatic Y axes description".

4. Now leave the dialog Macro Offline Trend and Cross Ref with

"OK".

Automatic Y axes description string formatting

Please take care on Y Min and Y Max string length and formatting: The description
strings may overlap each other like in the picture below if they are too long:

Therefore you have the possibility define the value formatting with Y Min and Y Max
strings and the font size.
The Y Min and Y Max defines the string formatting so: If you define '0.1' as the Y
Min and '1.234' as your Y Max the value formatting has one integer and three post
decimal positions.
The maximum number of post decimal position that appears in Y Min or Y Max will
determine the value formatting. This means that values are truncated in some
cases.

You are able to use the scientific notation in defining Y Min and Y Max. In this
case the values will be displayed exponentially.
With this notation the string length in the sample below was reduced from 7 to 4
characters ('100000' becomes '1E6').
And you must enter '-1e1' as Y Min and '1E6' as Y Max.
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String formatting can be defined in the Y Min and Y Max field in the macro
configuration dialog and during runtime.

Prepare The Project
1. Choose Project-> Init PPOs and click "OK". (The added PPO's were

initialized)

2. If you created a new teq you have to generate a new html file with 
Project-> Generate HTML...

3. Choose File-> Save All...

4. Compile and download your project now with PG5.

 

How To Use The Offline Trend Macros At Runtime

These sections describes how to use the offline trend macros during runtime. The
specific differences in using the offline trend macros is described in separate
chapters.

 
Zoom And Scroll Buttons

After uploading data, the curves will be painted. Now you can navigate with the
scroll and zoom buttons:
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Save Trend Curves To Local Hard Disk

It is possible, to save the recorded trends to the local hard disk of the client. The
curves will be saved in a csv-format. As a Java Applet has very limited access to
the resources of the host computer, certain limitations must be considered.

The file download works different with Microsoft VM as with Sun VM, you have to
change the security settings:
Microsoft VM: Java Security Settings
Sun VM: Signed Applets (For Sun VM PlugIn)

To download the the logfile click "Save Logs to file":
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Clear Logs

Curve points which are already loaded will be overwritten in the applet buffer if you
load them more than once. And new curve points will be added. Use "Clear Logs" if
you want to clear all the loaded trend curves.

 

Please see Offline Trend Overview for general information about how to use the
offline trend macros.

How To Use The Offline Trend Complete At Runtime

Overview

This section explains how the offline trend macro will be used at runtime. The
browser will show a view like this:



94

Saia-Burgess Controls Ltd. S-Web Editor Help

Advanced Functions

Start Load Data Uploads the selected trend in the list of activated PPO's trends.
Load Infos Loads the attributes to the selected entry in the activated PPO's

trends list
start date/time start date and time point of the range shown
end date/time end date and time point of the range shown
zoom buttons Increases or decreases the time axis
scroll buttons scroll back and forward on the time axis
activated PPO's
trends

The list of all activated PPO's trends.

PPO
Name:

PPO Name of the selected trend

RGB: Red Green Blue value for the curve
Min/Max: shown value range on the y-axis

Update:
Click on the "Update" Button after modify the RGB,
Min or Max values.

Add:
Insert a selected trend PPO's trend form the list of
available PPO's trends by clicking the "Add" button.

Removes:
Removes the selected PPO entry in the activated
PPO's list.

available PPO's
trends

The list of all available trends. During runtime new trends can be
added by clicking the "New" Button.

Clear Logs Clears the buffer
Save Logs to
file

Saves the data logged in buffer until now in a text file which can
be downloaded

 
Curve info The "Curve Info" list shows details about curve points selected

by the user.

 

 
Add a PPO's trend
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Select an entry from the list of available PPO's trends:

Click "Add" to add the selected entry to the list of activated PPO's trends:

Click "Load Infos" to load the number of points to be downloaded and the start/end
index. The 'load info' function will read some information of the selected curves. It
will count the number of samples which are already recorded in the PLC. If several
curves are added to the list on the right, the number of samples of these curves will
be added. Like this, the user can estimate how much time the loading will take.
This is very useful, if the user accesses the PLC via a slow connection like a
modem.
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Click on the entry in the list of activated PPO's trends to see and edit the details.
The edit-fields left from the 'Update' Button indicate the min and max values of the
respective trend. The two edit-fields below (Just above the list box) will be updated
only after a 'Load Info' command and indicate the position of the start- and the end
pointer of the curve in the DB structure of the PLC. The user can modify these
pointers to reduce the number of data to be loaded from the PLC. Because the
trends can be recorded event-driven, it is not possible to know the start- and stop-
time and date before having loaded all samples to the client. This is therefore the
only way how the user can select the area that he wants to load.

The loading can be done in several attempts. If the selection of a curve did not
cover the desired period, the user can modify the pointers to another position. The
data that will be loaded during a second phase will be added to the data that is
already present in the client.

Optional: Edit Min/Max, start/end index or RGB color. Edit a value press "ENTER"
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and click on the Update button.

Click "Start Load Data" to initialize the upload process. If the upload takes too
long, this process can be interrupted by pressing the button 'Stop Loading'. The
data that was loaded so far is not lost.
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After uploading data, the curves will be painted. Now you can navigate with the
scroll and zoom buttons:

Curve Info

The "Curve Info" list shows details about curve points.

Just click somewhere in the trend timeline. The selected point will be marked with
a green line.
The first entry on the list is the point selected by the user. The list shows details
about the point next to user selected point for every curve (only backwards).
The first green colored entry in the list shows you details about the point selected
by the user (Value is "USER !")

The screenshot shows a scalable offline trend painter, but it is the same in the
offline trend complete macro:
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Please see Offline Trend Overview for general information about how to use the
offline trend macros.

How To Work With Offline Trend Scalable In The Editor

Adapt The Offline Trend Scalable Macro Object Own Your Own
Needs

1. The macro contains some italic written comment text fields which should be
removed. Ungroup the offline trend macro object, select the text field
comments and delete them. What you now see is the blank macro-object.

The macro-object contains several event painters positioned under the other
objects (labeled with "EventP"). If you move some of the painters you will
see these special painters. You must not delete these EventP objects
because provide some parts of the macro functionality.The user will not see
them during runtime anyway.

2. There is also a "Curve Min/Max" and a "Curve info" section which is optional
(can be removed). This means they are not required by any variant, but they
provide additional functionality to the user.
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These edit boxes give you the possibility
to modify the y-min and max of your
curves during runtime. Please see the
section "Configure The Macro" further
down for details.

During runtime the user can select a point
in the y-axis. This "Curve info" list will
display details about curve points that are
next to the selected point. Please see the
section "How to use the Simplified Offline
Trend at runtime" further down for details

The macro object contains the painter for two possible variants. You can use the
"A-Variant" or the more simpler "B-Variant".
Please do now the steps in "Offline Trend Scalable A-Variant" or "Offline Trend
Scalable B-Variant".

Offline Trend Scalable A-Variant

Don't delete any objects outside the sections of the variant you don't want to use.
Except the painters in the optional sections and the comment text fields.

1. Ungroup the offline trend macro object if you don't have yet.

2. Select all the objects in the section of the "B-Variant" and delete them.

You can freely reposition and resize all the objects.

Offline Trend Scalable B-Variant

Don't delete any objects outside the sections of the variant you don't want to use.
Except the painters in the optional sections and the comment text fields.

1. Ungroup the offline trend macro object if you don't have yet.
2. For the B-Variant select and delete all the objects in the A-Variant section.

You can freely reposition and resize all the objects.

Curve Min/Max (Optional)
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These edit boxes give you the possibility to
modify the y-min and max of your curves
during runtime.

 

1. Select the edit boxes for the first curve.

2. Open the Cross Ref dialog and go to the tab General.

3. Change the outline color to the color of the corresponding curve (curve color
can be changed in the Macro Offline Trend dialog).
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You will see the outline colors only during runtime. The default outline color
is black.

4. Do the steps 1-3 for all trend curves.

5. If you have just two trend curves for example, you can delete the other edit
boxes.

Prepare The Project

1. Choose Project-> Init PPOs and click "OK". (The added PPO's were

initialized)

2. If you created a new teq you have to generate a new html file with 
Project-> Generate HTML...

3. Choose File-> Save All...

4. Compile and download your project now with PG5.

Create Your Own Offline Trend Macro
 

If you want to use your modified scalable as macro-object in further projects. You
can simply export all the objects as a new macro:

1. Select all objects which should be added to your own macro-object
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2. Group the objects with:

3. Choose Library-> Insert object Into library.

4. Save the created macro under a new name.

 

How To Use the Offline Trend Scalable At Runtime

This section explains how the offline trend macro will be used at runtime.

First Steps

"B-Variant" with optional "Curve info" and "Curve Min/Max:

1. Click "Load Infos" to see how many curve points are available for this trend.
If you use the "A-Variant" go directly to step 3 because there is no "Load
Infos" available. In "A-Variant" you are also able to load a specific number of
curve points, but you can't see how many points are available.

2. Leave the value "ALL" if you want to load all available points or enter a
number:

3. Click "Start Load Data". The trend curves are loading now. You can cancel
the download with "Stop Load Data" if it takes too much time and enter a
lower number of points to be loaded.
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4. Use the scroll and zoom buttons if the trend looks like in the picture below:

Curve Min/Max

With the objects in the optional section "Curve Min/Max" you are able to modify
the minimal and maximal value for each curve during runtime:

1. Modify the "Min" or "Max" of a trend

2. To update the trend click "Y Range Update".

As you see the automatic description will be updated too.

Curve Info

The "Curve Info" list shows details about curve points.

Just click somewhere in the trend timeline. The selected point will be marked with
a green line.
The first entry on the list is the point selected by the user. The list shows details
about the point next to user selected point for every curve (only backwards).
The first green colored entry in the list shows you details about the point selected
by the user (Value is "USER !")



Saia S-Web-Editor Help | © 2009 Saia-Burgess Controls Ltd. | 07.10.2009

Saia-Burgess Controls Ltd. S-Web Editor Help

Advanced Functions

Please see Offline Trend Overview for general information about how to use the
offline trend macros.

How To Use The Offline Trend Minimal At Runtime

This section explains how the offline trend macro will be used at runtime.

First Steps

The offline trend minimal:

1. Click "Load Infos&Datas" to start loading trends informations and data.

2. Leave the value "ALL" if you want to load all available points, or enter a
number so only the entered number of last logged point will be loaded:

3. The trend curves are loading now. You can cancel the download with "Stop
Load Data" if it takes too much time and enter a lower number of points to
be loaded.
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4. Use the scroll and zoom buttons if the trend looks like in the picture below:

 

1.23.3.4 Client-Sided Trending

Introduction

This chapter gives you an overview about the online trend macros. The differences
in handling for every macro is described in a separate chapter:

1. Online Trend Complete

2. Online Trend Minimal

3. Online Trend Scalable

The Online Trend Painters are macro object which can be imported with the menu 
Library->Get object from library. The Online Trend Painter creates the

curves during runtime and stores these data into a buffer. The data sources are
regular process points which will be recorded by the browser client. The number of
values that will be recorded by the trend-object can be configured. If the number of
samples exceeds this size, the oldest entries will be erased. If the user leaves the
view the recorded data will be lost.

How To Work With Online Trend Macros In The Editor

The trend macros consist of several painter objects which are grouped to one
macro-object. The user can ungroup the macro and access each element
separately. Most of these objects are not editable with the standard dialog of this
editor.

Anyway, all references inside these objects can be accessed and modified by
using the CrossRef function. As the trending macro contains a rather complex
functionality, it is not recommended to modify the references, but the user can
easily move or resize the objects of this macro.

The objects of the trend-macro communicate with each other via container
variables. The names of these containers will be extended by a unique code at the
moment when the user imports the macro. This is necessary to generate an
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unique instance of the trend macro object. The names to be generated may have
the form e.g. '@MACRO_NewYMax.122345676788990'. The user should not
modify such values, as they are generated and modified automatically. If you
export a modified macro, the editor will automatically remove these indexes. So,
you don't have to care about it.

Insert An Online Trend Into Your View
 

1. Create a new Teq view in the project you want to insert the Online Trend
Painter. Do this with Project->Add to Project-> New.

(How to create a new project is described in the chapter Getting Started)

2. Insert the Online Trend Macro object into your teq view choose Library-
>Get object from library

3. Change to your "MacroLib" directory. Select the file name of the online trend
macro you want to insert:

Online Trend Complete: "OnlineTrendComplete.tlb"

Online Trend Minimal: "OnlineTrendMinimal.tlb"

Online Trend Scalable: "OnlineTrendScalable.tlb"

The inserted Online Trend Complete:

Online Trend Minimal:
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Online Trend Scalable:

 
Configure The Macro

1. Double-click on the inserted object to open the Cross Ref dialog

2. Click on the entry ".._Macro Online Trend_Repaint:
_@MACROActiveTrends." in the Advanced Select tab. Alternatively, it is

also possible to ungroup the trend-macro and to double click on the painter
object which will display the trend curves (uppermost object).
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3. Go to the tab Macro Online Trend
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4. Click "Select" to see which PPO's are available. The user shall select
regular process points which contain one single value. These process points
will be available during runtime. They will be added to the list 'Available
Process Points' (on the right side).The user can select at runtime, which of
these curves should be displayed or not. The user will select a variable from
the list 'Available Process Points' and add it to the list 'Activated Process
Points' to make it visible.

5. Confirm your choice with "OK"

6. Define the curve color and the Y-Min and Max value. These values will be the
defaults when the object starts in the browser. The scaling can also be
changed later during runtime.

7. Click "Add" to add your curve define to the trend

8. Repeat the steps 7-10 for all curves you want to add to the trend.
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If you want to change a curve definition, click on the entry in the list do your
modifications and confirm with "Update" .

Prepare The Project

1. Now leave the dialog Macro Online Trend and Cross Ref with "OK".

2. Save your view with File-> Save

3. Choose Project-> Init PPOs and click "OK". (The added PPO's were

initialized)

4. If you created a new teq you have to generate a new html file with 
Project-> Generate HTML...

5. Choose File-> Save All...

6. Compile and download your project now with PG5.

 

How To Use The Online Trend Macros At Runtime

These sections describes how to use the online trend macros during runtime. The
specific differences in using the online trend macros is described in separate
chapters.

Save Trend Curves To Local Hard Disk

It is possible, to save the recorded trends to the local hard disk of the client. The
curves will be saved in a csv-format. As a Java Applet has very limited access to



112

Saia-Burgess Controls Ltd. S-Web Editor Help

Advanced Functions

the resources of the host computer, certain limitations must be considered.

The file download works different with Microsoft VM as with Sun VM, you have to
change the security settings:
Microsoft VM: Java Security Settings
Sun VM: Signed Applets (For Sun VM PlugIn)

 

Set Your Own Start Date/Time

Click "set manual" enter/time, press "ENTER" and click "set auto".
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Please see Online Trend Overview for general information about how to use the
online trend macros.

 

How To Use The Online Trend Complete At Runtime
 
Overview

This section explains how the online trend macro will be used at runtime. The
browser will show a view like this:
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If you edit a text field always press enter to confirm the value

start date/time start date and time point of the range shown
end date/time end date and time point of the range shown
scroll buttons scroll back and forward on the time axis
set manual Click this button if you want to set the start point of the range

shown manually.
activated PPO's
trends

The list of all activated PPO's trends.

PPO
Name:

PPO Name of the selected trend

RGB: Red Green Blue value for the curve
Min/Max: shown value range on the y-axis

Update:
Click on the "Update" Button after modify the RGB,
Min or Max values.

Add:
Insert a selected trend PPO's trend form the list of
available PPO's trends by clicking the "Add" button.

Removes:
Removes the selected PPO entry in the activated
PPO's list.

available PPO's
trends

The list of all available PPO's trend. During runtime new trends
can be added by clicking the "New" Button.

PPO
Name:

Enter the name of the PPO you want to add

RGB: Set a RGB color for the new curve
Min/Max: shown value range on the y-axis
New Click on the "New" button to add the defined PPO

zoom buttons increases or decreases the time axis
Clear Logs Clears the buffer
Save Logs to
file

Saves the data logged in buffer until now in a text file which can
be downloaded

 

 
How to use the Online Trend at runtime
 



Saia S-Web-Editor Help | © 2009 Saia-Burgess Controls Ltd. | 07.10.2009

Saia-Burgess Controls Ltd. S-Web Editor Help

Advanced Functions

Add an activated PPO's trend

Select an entry from the list of available PPOs and click "Add".

Modify properties of an activated PPO's trend

Select a trend from the list on the left. The name, color, YMin and YMax will be
copied to the edit-fields above. The properties can be modified in these edit-fields.

After changing a property please confirm by pressing "ENTER". If you changed the
properties update the curve by pressing "Update".
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Add a PPO that is not on the list of available PPOs

With the editor, the user has added the PPO's that shall be available for trending at
runtime.

Additionally, it is possible to add a PPO at runtime. This can be done by indicating
the address of the respective PPO. The use of symbolic names is not possible at
this stage.

Enter The name of the PPO that is not on the list of available PPOs, confirm with
"ENTER" and click on the "New" Button.
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Please see Online Trend Overview for general information about how to use the
online trend macros.

How To Use The Online Trend Minimal At Runtime

This section explains how the online trend macro will be used at runtime.

The online trend minimal:
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Use the scroll and zoom buttons to navigate in your trend.

 

Please see Online Trend Overview for general information about how to use the
offline trend macros.

How To Work With Online Trend Scalable In The Editor

For information about how to use the Online Trend Scalable in the editor please
see the chapter Offline Trend Scalable. Its is basically the same except there is no
"A" or "B-Variant".

 

1.23.3.5 Viewing Trend Logfiles

The Offline Saved Trend Painters are macro objects which can be imported with
the menu Library->Get object from library. These macro objects need

no further configuration. They are used to load previously recorded trend curves
from a CSV file. Therefore you needn't to configure any PPOs.



Saia S-Web-Editor Help | © 2009 Saia-Burgess Controls Ltd. | 07.10.2009

Saia-Burgess Controls Ltd. S-Web Editor Help

Advanced Functions

How To Use The Offline Saved Trend Complete At Runtime
 
Overview

This section explains how the offline saved trend complete macro will be used at
runtime. The browser will show a view like this:

If you edit a text field always press enter to confirm the value

start date/time start date and time point of the range shown
end date/time end date and time point of the range shown
scroll buttons scroll back and forward on the time axis
activated PPO's
trends

The list of all activated PPO's trends.

PPO
Name:

PPO Name of the selected trend

RGB: Red Green Blue value for the curve
Min/Max: shown value range on the y-axis

Update:
Click on the "Update" Button after modify the RGB,
Min or Max values.

Add:
Insert a selected trend PPO's trend form the list of
available PPO's trends by clicking the "Add" button.

Removes:
Removes the selected PPO entry in the activated
PPO's list.

available PPO's
trends

The list of all available PPO's trend. During runtime new trends
can be added by clicking the "New" Button.

PPO
Name:

Enter the name of the PPO you want to add
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RGB: Set a RGB color for the new curve
Min/Max: shown value range on the y-axis

zoom buttons increases or decreases the time axis
Load Data... Loads trend data form a file
Clear Logs Clears the buffer
Save Logs to
file

Saves the data logged in buffer until now in a text file which can
be downloaded

 

Load trend data

Click "Load trend data" to load trends from a file.

Please read the chapter Java Security Settings (for Microsoft VM) or Signed
Applets (for Sun VM) if the open dialog don't appears.

Add an activated PPO's trend

Select an entry from the list of available PPOs and click "Add".

Modify properties of an activated PPO's trend

Select a trend from the list on the left. The name, color, YMin and YMax will be
copied to the edit-fields above. The properties can be modified in these edit-fields.
After changing a property please confirm by pressing "ENTER". If you changed the
properties update the curve by pressing "Update".

 

The Offline Saved Trend Painters are macro objects which can be imported with
the menu Library->Get object from library. These macro objects need

no further configuration. They are used to load previously recorded trend curves
from a CSV file. Therefore you needn't to configure any PPOs.

How To Use The Offline Saved Trend Minimal At Runtime

This section explains how the offline saved trend minimal macro will be used at
runtime.

The offline saved trend minimal:
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Use the scroll and zoom buttons to navigate in your trend.

Load trend data

Click "Load trend data" to load trends from a file.

Please read the chapter Java Security Settings (for Microsoft VM) or Signed
Applets (for Sun VM) if the open dialog don't appears.

 

The Offline Saved Trend Painters are macro objects which can be imported with
the menu Library->Get object from library. These macro objects need

no further configuration. They are used to load previously recorded trend curves
from a CSV file. Therefore you needn't to configure any PPOs.

How To Work With Offline Saved Trend Scalable In The Editor

For information about how to use the Offline Saved Trend Scalable in the editor
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please see the chapter Offline Trend Scalable. Its is basically the same except
there is no "A" or "B-Variant".

How To Use The Offline Saved Trend Scalable At Runtime

Load trend data

Click "Load trend data" to load trends from a file.

Please read the chapter Java Security Settings (for Microsoft VM) or Signed
Applets (for Sun VM) if the open dialog don't appears.

 

 

1.23.4 Alarming Macros

1.23.4.1 Alarming Overview

Introduction

This chapter gives you an overview about the alarm macros. The differences in
handling for every macro is described in a separate chapter:

1. Online Alarm List

2. Online Alarm History

3. Offline Alarm History

The alarm painters are macro objects which can be imported with the menu 
Library->Get object from library. These macros can be used to load

historical logged alarm data from a Saia®PCD and display the data in alarm lists.
The process signals are monitored and alarms
picked up independently of the web browser in the PCD control. The actual alarm
function is implemented in the firmware on the PCD control. It is activated and
parameterized using CSF (Call System Function) instructions, or SFC (System
Function Call) instructions for xx7 controls. A Fupla FBox library for the PCD
Classic is available. The alarms are stored in alarm lists in the nonvolatile internal
memory of the PCD control.

How To Work With Offline Alarm History In The Editor

The alarm macros consist of several painter objects which are grouped to one
macro-object. The user can ungroup the macro and access each element
separately. Most of these objects are not editable with the standard dialog of this
editor.

Anyway, all references inside these objects can be accessed and modified by
using the CrossRef function. As the trending macro contains a rather complex
functionality, it is not recommended to modify the references, but the user can
easily move or resize the objects of this macro.

The objects of the alarm-macro communicate with each other via container
variables. The names of these containers will be extended by a unique code at the
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moment when the user imports the macro. This is necessary to generate an
unique instance of the alarm macro object. The names to be generated may have
the form e.g. "@MACRO_NewYMax.122345676788990". The user should not
modify such values, as they are generated and modified automatically. If you
export a modified macro, the editor will automatically remove these indexes. So,
you don't have to care about it.

Insert An Alarming Macro Into Your View
 

1. Create a new Teq view in the project you want to insert the alarm painter. Do
this with Project->Add to Project->New.

(How to create a new project is described in the chapter Getting Started)

2. Insert the alarm macro object into your teq view choose Library-> Get
object from library

3. Change to your "MacroLib" directory. Select the file name of the offline trend
macro you want to insert:

Online Alarm List: "MacroAlarmingDefOnline.tlb"
Online Alarm History: "MacroAlarmingHisOnline.tlb"
Offline Alarm History: "MacroAlarmingHisOffline.tlb"
The inserted Online Alarm List:

Online Alarm History:
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Offline Alarm History:

Configure The Macro

The following section explains how to configure the alarm macros painter (it is
basically the same in all alarm macro variants):

1. Double-click on the inserted object to open the Cross Ref dialog

2. Click on the entry ".._Macro his Offline Alarm..." (Offline Alarm History) in
the Advanced Select tab.

Online Alarm List: ".._Macro Def Online Alarm..."
Online Alarm History: ".._Macro his Online Alarm..."
Offline Alarm History: ".._Macro his Offline Alarm..."

3. Alarm List PPO Name (in all alarm macro variants):

First of all you have to enter the alarm list PPO name. The alarm macro will
take the alarm list name from the given PPO.
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4. Click the 'Select' button next to the 'Alarm List PPO Name' text field to
choose the PG5 symbol (e.g. A.Alarm.ThisAlarmList.MyName). By the PG5
symbol the Alarm Macro is referenced to the corresponding alarm list in the
PCD.

The PG5 symbol of the alarm list is automatically generated when using the
Alarming FBox library. The user can define the Alarm list name by entering
resp. modifying the name of the FBox.
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The Alarming library is provided together with the Web-Editor and can be
installed or copied into the PG5&/Libs/usr FBox directory. For more details
refer to the online help of the FBox library.

5. Alarm Texts (optional):

If you activate the drop down 'Alarm Texts From CSV File' the java-applet
loads the alarm descriptions from the CSV-file, otherwise the applet will load
the alarm descriptions from the DB.

If you want to use a csv file for your alarm descriptions, activate the
checkbox 'Alarm Texts From CSV File'. Enter the size (number of alarm
types) of your alarm list and confirm your choice with 'OK'. Now use the
menu function Project->Generate HTML TAGS CSV file. The editor

will generate a new csv file. Open the csv file in a text editor like notepad and
define your alarm description by replacing the default text like shown in the
picture below:
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Use the menu function Project->Project configurations... and

enter the filename of the generated csv file into the field 'csv file' (in the tab
'Project - Applet Advanced').

6. Alarms State Colors:

For every of the following states you can define a color

No state no state
ON alarm is active
ON ACKED alarm is active and acknowledged
OFF alarm is inactive
OFF ACKED alarm is inactive and acknowledged

example alarm list:

7. Filter - Sort:

'Filter - Sort' appears only in the configuration dialog of the Online Alarm List
(see chapter Online Alarm List for details):
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Prepare The Project

1.If you created a new teq you have to generate a new html file with 
Project-> Generate HTML...

2.Choose File-> Save All...

3.Compile and download your project now with PG5.

 

1.23.4.2 Online Alarm List

How To Use The Online Alarm List At Runtime
 
Overview

The Online Alarm List contains an overview of all alarm types. Actions which are
performed in this list will be applied to all occurred alarms of the selected alarm
type. The user has the possibility to set filters and to choose between several
sorting modes.
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ID, Alarmtext and Counter refer to the alarm type. Time On, Time Off and ACK
refer to the last alarm from ID defined type

ID Unique alarm type Identifier
Alarmtext alarm type description text
Time On At this moment the alarm became active
Time Off At this moment the alarm became inactive. '---' means that the

alarm is still active
ACK In the column ACK shows, whether the alarm is acknowledged

(ACK) or not acknowledged (NCK)
Counter Shows how many alarms occured of the respective alarm type
Acknowledge
Selected
Alarms

Acknowledges all alarms of the selected alarm types

Delete
Selected
Alarms

Deletes all alarms of the selected alarm types

Acknowledge
Alarm List

Acknowledges the entire alarm list

Delete Alarm
List

Deletes the entire alarm list

Total Entries Number of alarm types

Filter Mode No Filter - shows all alarm types
Active Alarms - shows only the alarm types which are active at the
moment
Alarms count - shows only alarm types which were at least once
active
Active or NAK Alarms - shows alarm types which are active or not
acknowledged

Sort Mode Not Sorted - not sorted
Active Time Sorted - the newest alarm is on top

Select Mode Click this button to switch between single and multi-line selection
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1.23.4.3 Online Alarm History

How To Use The Online Alarm History At Runtime
 
Overview

Offline Alarm History is a time sorted list containing the occurred alarms. The
newest alarm appears on top.
The java-applet loads only the alarms which are shown on the actual page. In the
Online Alarm History the user can perform actions like acknowledge or delete
alarms.

 
TID Unique alarm type Identifier
Alarmtext alarm type description text
Time On At this moment the alarm became active
Time Off At this moment the alarm became inactive. '---' means that the

alarm is still active
ACK In the column ACK shows, whether the alarm is acknowledged

(ACK) or not acknowledged (NCK)
Ack Selected
Alarms

Acknowledges all selected alarms

Delete
Selected
Alarms

Deletes all selected alarms

Ack Alarms
Type

Acknowledges all alarms of a type. Select any alarm of the type
you want acknowledge all alarms of.

Delete Alarms
types

Deletes all alarms of a type. Select any alarm of the type you want
delete all alarms of.

Ack Alarm ListAcknowledges the entire alarm list
Delete Alarm
List

Deletes the entire alarm list

Total Entries Number of occurred alarms

1.23.4.4 Offline Alarm History

How To Use The Offline Alarm History At Runtime
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Overview

Offline Alarm History is a time sorted list containing all occurred alarms. The
newest alarm appears on top. The list is empty at the beginning, the user loads
the alarms by clicking on 'Load Alarm List'. 'Total Entries' indicates the number of
existing alarms. 'Loaded Alarms' the number of already loaded alarms. By clicking
on 'Save To File' a CSV-file will be generated automatically. The CSV-file can be
viewed in any spreadsheet program.

You can sort the list by clicking on the title of a column. Click on 'Time On' to sort
the alarms in the order they occured.

 
TID Unique alarm type Identifier
Alarmtext Alarm type description text
Time On At this moment the alarm became active
Time Off At this moment the alarm became inactive. '---' means that the

alarm is still active
ACK In the column ACK shows, whether the alarm is acknowledged

(ACK) or not acknowledged (NCK)
Load Alarms
List

Loads the alarms

Save To File Generates a CSV-file containing all alarms
Loaded /
Total Entries

Number of occurred alarms

 
Save Alarm List To Local Hard Disk

Screenshot of the CSV-file generated by clicking on 'Save To File':
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The file download works different whether you use a Microsoft VM or a Sun VM,
you have to change the security settings:
Microsoft VM: Java Security Settings
Sun VM: Signed Applets (For Sun VM PlugIn)

1.24 Editor Reference Guide

This section describes all functions and menus that are available for the S-Web
Editor.

· Main Window

· Property Window

· Group Functions

· Library Functions

 

1.24.1 Main Window

File Menu

New
Projec
t

Creates a new project file

Open
Projec
t

Opens an existing project file

Close
Projec
t

Closes the current project files

Save
All

Saves the entire project

New
file...

Creates and inserts new file to the project

Open Opens a TEQ view
Close Closes the actual opened TEQ view
Save Saves the actual TEQ view
Save
As...

Save the actual TEQ view with a new filename

Close
All

Closes all opened files

Print Lets you specify which printer is used by the print command and which
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setup
…

paper source and orientation applies

Print
previe
w

Shows a preview of the print.

Print Prints out a graphical view file *.teq including a cross-reference of all its
painter objects

Exit Closes the S-Web Editor

Edit Menu

Undo

Undo the last action

Redo Redo the previously undone action

Cut

Cut the selection an put it on the clipboard

Copy Copy the selection an put it on the clipboard
Paste Insert clipboard contents
Delete Delete selected painters
Select
All

Selects all painters

 
View Menu

Toolbar

Makes the toolbar visible/invisible.

Status Bar Show or hide the status bar
Painters Library Toolbar Show or hide painters library toolbar
Layout Toolbar Show or hide layout toolbar
Project Files Tree Toolbar Show or hide project files tree toolbar
Painter Config Tree Toolbar Show or hide painter config tree toolbar

Zoom

Zoom in/out view

 

Project Menu

Add to project  
New Create and insert a file into S-Web Editor project

File Inserts files into S-Web Editor project
Remove from
Project...

Removes a file from project.

Remove/Delete from
Project...

Remove a file from project and delete it from disk

Import PPOs file
(tcr)...

Imports an existing TCR file into your project

Import Containers file
(itq)...

Imports an existing ITQ file into your project

Reload HDLog Files... Reloads project's HDLog files
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Project
Configurations…

Configures the project view defaults. If you change a value
in this window, only the views you create after, have the
new properties.

 Project Configuration ...: TEQ Configurations

Width: Default width of views when creating new views from S-Web
Editor. During runtime it defines HMI's width.

Height: Default height of views when creating new views from S-Web
Editor. During runtime it defines HMI's height.

Background
Color:

Default background color of views & painters. This is also the
HTML's background color.

Foreground
Color:

Default outline color for painters

Font: Default font, font style and font size for new painters
Outline Width: Default outline width for painters (in pixel)
Outline Style: Default outline style for painters (solid, dashed or dotted)
background
TEQ:

Default background TEQ view (see chapter Using Fore- And
Background TEQs)

foreground TEQ: Default foreground TEQ view (see chapter Using Fore- And
Background TEQs)

csv files
(update):

The editor will create the CSV files defined in the list 'csv files
(update)' if you click Project->Generate HTML TAGS CSV
file

After the CSV file is created once, the 'Generate HTML TAGS
CSV file' functionality updates your existing CSV files.
If you define a new 'HTML TAG' reference, the editor will
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automatically add it (on the first line) to your existing CSV files, if
you use 'Generate HTML TAGS CSV file'. The editor keeps all
your translations that you have already made. If you remove
'HTML TAG' references from your HMI, the editor will show a
dialogue. You have the choice between keep or remove old 'HTML
TAG' references.

(see chapter Multilingual HMIs)
scalable html: Define HTMLs that resize the HMI during runtime according to a

defined factor. Scale your HMI up to 200% for example without
need to change your TEQ-Views. MicroBrowser and IMaster
Applet will resize the TEQ-Views at runtime if you type in the
URL of your new 'scalable' HTML file instead of your standard
HTML. In the example in the screenshot we defined an HTML for
50% and one for 200% of the original size (640x480).

Factor 0.500000 means 50% of 640x480 which is 320x240
Factor 2.000000 means 200% of 640x480 which is 1280x960

Click 'Add' to define new scalable HTMLs, you don't have to type
in anything manually. After the next 'Build All' the S-Web Editor
will generate and add the new HTML files to your project.

Saia HDLog
Files:

Path to the HDLog files generated by the PG5 Tool

Saia Project
type:

Saia Standard or Saia XX7

Project configurations ...: Applet Advanced
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applet params
Debug: Java console debug messages. If this checkbox is activated the

Java console shows exception messages from the Java Virtual
Machine.
To open the Java console if you work with internet explorer and
Sun java plugin use the menu Tools->Sun Java Console

To open the Java console if you work with internet explorer and
Microsoft plugin use the menu View->Java Console

Order per view: If this option is activated the client applet only gets the PPOs of
the actual view from the target.

Date/Time
Display Mode
PM AM

Activates PM/AM display format of time stamps in trend and
alarm macros

Encode Special
Chars:

Activate this option to ensure that PPOs with special chars (other
than 7 Bit ASCII) in their name will be processed correctly

Decimal Symbol Defines the decimal symbol for floating point values in log files
made by Trending Macros.

period: Update period of process points (PPOs) in milliseconds

main teq: Initial view when loading the HMI

Message Box: Message Box (MsgBox.teq) for error messages. E.g., this dialog
shows a message if the user tries to write a value which is out of
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the range given by min. and max. (see chapter Initialising
Processpoints).

Message box
teq:

Filename of the message box TEQ. In most cases you shouldn't
modify this filename. Erase the filename if you don't want to see
any warnings or error messages during runtime.

Nbr Errors /
Warn:

If a CGI request fails N times (N = Nbr Errors / Warn), the
Message Box shows a warning. If you define 3 for example, one
failed CGI request will not force a warning message. Only if three
CGI requests failed consecutively a message will be shown.

Warn display
time:

Number of seconds before the warning buttons disappears
automatically. (0 means that it will not disappear automatically)

HTML
Parameters in
csv file:

Activate this option if you want to use CSV files

csv file: This CSV file will be reloaded periodically. If you have a 
Multilingual HMI the CSV file should be the filename of your
default language CSV file.

static csv file: this CSV file will be loaded at applet start and never reloaded
Action mode:  

BROADCASTE
D ACTION

In the case of overlapping painters, all painters will receive the
given event (for example a mouse down event).

CONSUMED
ACTION

The first painter that receives the action (and implements an
action) will consume it.

Browsing mode:  
DEFAULT In the DEFAULT mode every client navigates independently from

each other.
MIRROR The name of the actual view will be stored in a PPO. So every

client will see the same view at the same time.
Mirror PPO
Name:

The name of the PPO which contains the name of the actual view
during runtime.

Loading mode: These options control the way how the Java Virtual Machine loads
the MMI. The upload mechanism can be optimized by the user for
different situations.

Standard Load Default setting.
Loads all TEQ-views at initialization and stores all view's objects
into the RAM memory during runtime. Most users don't mind the
HMI using some time when it first starts up, but they accept no
performance draw-backs in normal operation. This setting allows
the fastest possible reactions at runtime.

Load When
Needed & Keep
Objects

Optimized for operation using slow modem lines. The client
browser is a regular PC with sufficient RAM memory.
Loads the TEQ-views and stores view's objects into into the ram
memory (keep object instances) when the user first visits the
TEQ-view.

Load When
Needed & Keep
Teqs

Optimized for operation using slow modem lines. The client
browser has a Java VM with limited RAM memory.
Loads the TEQ-views only when the user first visits them and
keeps only the TEQ-view file in RAM memory (not the TEQ-view's
objects)

Load When
Needed & Keep
Nothing

Optimized for operation using slow modem lines. The client
browser has a Java VM with very limited RAM resources.
Loads the TEQ-views only when the user visits them and after a
TEQ-jump all TEQ-view's objects and the TEQ-view file will be
erased from RAM memory.

 Project Configuration ...: Build Advanced
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With the settings in this tab you can decide what happens if you click on the 'Build
All' button.

Build All

Add Macro files
in project sub
folder

Activate this if you want to deploy your project together with the
macro dialogues used in your project. If you do not set this option
and open the project in another editor that has not used some of
the macros, the respective dialog will not be available and the
CrossRef dialogue will open instead.

Save modified
files (TEQ)

All modified files will be saved if you click 'Build All'

Update
containers/ppo
init files (ITQ/
TCR)

The modified files will be saved and the Container/PPO
initialisation files (ITQ/TCR) will be updated

Generate html
file

Generates the HTML file

Generate/
Update
language csv
files

Generates or updates CSV language files

Generate/
Update Scalable
html files

Generates or updates scalable HTML files

Generate Spider
Font files

Creates the SpiderControl FNT font files according to the defined
HTML Tags and fonts

Convert project's
GIF to BMP

Creates for every GIF a monochrome image in the BMP format

Generate Saia
Converted
runtime files

Generate HTML runtime files also used by the PG5 Tool to
compile the project

Force Teq Files
saving as 5_13

Choose this option if you use MicroBrowser clients that do not
support a teq format higher than 'g'. If you modify an existing
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format (in["..
\Html"] folder)

project, it is automatically converted to the new format unless you
select this option. This option is only active as long as you do not
use functions that require a newer format. If you do so, the editor
will issue a warning.

5.14 file format will not run on older MicroBrowsers unless you
make a firmware update.

Make Memory
Foot Print
Check

Make a memory foot print check according to the given hardware
profile

Project configurations ...: Advanced

2 Bits
colors
paint

Shows the whole HMI in grey scales to see for example how the eDisplay
would display the HMI

Hardwar
e profile

Path to the folder that contains the hardware profile. The S-Web Editor
uses the hardware profile to make the memory foot print check. This can
be useful if you work with the eDisplay to survey for example the
maximum number of Container variables

Macro
Lib Path

Defines the path of the Macro Library (supports relative and absolute
paths)

Grid configurations...

Configures the grid:
Grid snap aligns all selected objects to the actual grid settings. If set to true, all
objects will be aligned to the current grid settings. An object will only be aligned if
the user selects and moves it. Changing this setting from false to true will not
affect objects until they are re-selected.
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Grid visible Shows or hide the grid
Grid snap Grid snap mode
X <-> Horizontal grid spacing

Y <-> Vertical grid spacing
Grid Color Sets the grid color

Init
Containers...

See chapter Initialising Containers

Init PPOs... See chapter Initialising Processpoints (PPOs)
Generate
HTML...

Creates a HTML source code including the projects applet and
components.

Build All Build project files (see Project Configuration)
Download
Project

Download project files via FTP

Generate
HTML TAGS
CSV file...

see chapter Multilingual HMIs

Generate
Cross Ref
file...

Generates a Cross Ref file of all project objects (named
'projectnameCrossRef.txt') in the project directory

Generate
Scalable
HTML files

Generates project defined scalable HTMLs

Generate
Spider Font
files

Generates font files containing all characters needed in the
project's HTML Tags

Convert
project's Gif to
Bmp

Converts all GIF images to grey scale BMP images

TEQ view configurations...
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Width: Default width of views
Height: Default height of views.
Background
Color:

Default background color of views & painters

Foreground
Color:

Default outline color for painters

Font: Default font for new painters
Outline Width: Default line width for painters
Outline Style: Default line style for painters
background
TEQ

Default background TEQ view

foreground
TEQ

Default foreground TEQ view

Pr
oje
ct
inf
o
re
pla
ce

Please make a backup of your HMI before using 'Project info replace' because
modifications will take effect immediately and can not be undone.

This function is used to replace an info over the whole S-Web Editor project. An info can be
any reference to one of the following types: PPO, HTML TAG, STRING, FILE, CONTAINER,
TEQ INDEX, URL, PASSWORD PPO, PASSWORD CONTAINER, CGI, FKEY.

In the example below we replaced the PPO with the name 'PDP,,R1003,d' with the PPO 'PDP,,
R1005,d' over the whole S-Web Editor project.
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Help Menu

About..

Opens a dialogue showing version information and more details about
the S-Web Editor software release

 

Layout Menu

Align  

Left Left edge selected objects
Right Right edge selected objects
Top Top edge selected objects
Bottom Bottom edge selected objects
Center  
Horizontally Center horizontally
Vertically Center vertically
Make same
size

 

Width Resize selected object on same width
Height Resize selected object on same height
Both Resize selected object on same width and height

Order  
To Back Sends selected object to back
To Front Sends selected object to front
Group  
Group Group selected objects
UnGroup Ungroup selected objects
Edit Polygon
points

Edit polygon’s points Activate this to alter each corner point of an
already drawn polygon.

Cross Ref... See chapter Group Functions
Rotate
Polygon

You can rotate the selected polygon painter by using this menu
function or by clicking on the corresponding button:
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Tools menu

Tool Configurations Tool configuration dialogue

Update project's PPO's
format when Select PPO

Defines the behaviour of the 'Select PPO' dialogue

Saving Actions that have to be done automatically before
executing 'Build All'

PPO Select Dlg mode Defines the presentation of the 'PPO Select'
dialogue

 

 

 

1.24.2 Property Window

If you double click on a painter a standard dialogue with all properties will appear.
They are grouped in different tabs. Every painter has other properties therefore the
same tabs does not necessarily have the same possibilities.

Dialog Tabs
 

General Tab

The user can set the position, size, interior & outline color, line width and font for
the active painter. This tab is available for all painters.
The 0/0 position is at the upper left of a drawing. The X-axis goes from left to right
and the Y-axis from top to bottom. The fonts that can be selected are resources
supplied by the Java Virtual Machine which currently runs these applications, so



144

Saia-Burgess Controls Ltd. S-Web Editor Help

Editor Reference Guide

the results may slightly vary when running in a different environment like a browser,
and there might be minor differences between different browsers, as they do not
use the same Virtual Machine. It is not possible to access fonts, which are loaded
into the operating system of the PC.

With 'Hide and Disable for Groups' you can hide or disable a group. You can also
define a condition, which must be true if the group should be hidden or disabled.
The hide/disable will be set for all that group's painters.

Painter X Offset and Painter Y Offset allows you to define a offset in pixel. The
client browser calculates the new painter position each repaint during runtime.

Repaints Tab

With this tab you can define the data's which should be displayed by the painter.
Furthermore you can control the visibility of the painter. This is available for all the
painters such as 'Static Text', 'Edit Box', 'Image', 'Bargraph' and 'Button'. The types
that are available for certain graphical objects are CONTAINER, FILE, HTML TAG,
PPO and STRING.

CONTAINER - A container is a local variable, which has a scope within the actual
applet/view. Containers are used to exchange values between different painters in a
view or between different views of the same applet.

FILE - This is used to browse an image file of type *.gif and the file name is placed
in the field Name.

HTML TAG - This is used to configure a text as a HTML tag. If the Type = STRING
and Name = 'Switched_On' is configured then the HMI will always obtain the text
'Switched_On'. If the Type = HTML_TAG and Name = 'Switched_On' is configured
then the HMI also obtains the text 'Switched_On' if you don't do anything else.
However, in the HTML-start page, <your_projectname>.html, you can manually
add lines of the form
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<PARAM NAME='<Switched_On>' VALUE='On'>
Depending on the Value, the text 'On' will be displayed in the HMI.

PPO - Stands for Process Point. A process point corresponds to a PCD variable
(R, T/C, F, I/O,…) that is used within the Web application. This variable can be a
symbolic name taken from the resources of PG 5 or it can be directly used in the
tag form PDP,,R1000,D. Refer to the Web Server Manual 26/790 of how to define
the tag with other media and/or formats.

STRING - This is used to display a simple text string.

For example to change the displayed string of a button, set 'Edit a Source' true
and type your string in the 'Name' field.

To insert an image you have to create an image painter then make a double click
on it, click on the tab 'Repaints'. Set 'Edit a Source', choose the entry 'FILE' in the
drop down menu 'Type', click on 'Browse' and select the image. Set 'On Condition'
if you want to show the image only if a specific condition is true. Click on 'Hide
Painter On Condition' if you want to hide the Image if a defined condition is true.

In the 'Repaints' properties of the 'STATIC TEXT' painter you can define the string
you want to show: Click on Edit a Source, choose the Type STRING in the drop
down menu and type the text in the Name field.

You can configure two repaint sources for each painter. Use the 'On Condition'
feature to activate a source depending on the content of a process point.

Actions Set Variables

This tab is only available for 'Button' painters.
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Set Variables during mouse down or mouse up event.

Actions Toggle Increment Variables

This tab is only available for 'Button' painters.

You can also toggle or increment a variable on button mouse event.

Actions Jump

This tab is only available for 'Button' painters.
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With 'View Jump' you can jump to a specific view defined by the view name. With
the action 'Back Button' the browser jumps to the view where the user came from.
This information is automatically cached in the 'LastPage' Container. With 'URL
Jump' the browser jumps to the defined URL if the user clicks on the button.

You can also set a variable by the mouse down or up event, toggle a button or
increment a variable.

Hide and Disable Painter

In the tab 'Hide and Disable Painter' you can hide or disable a painter. You can
also define a condition, which must be true if the painter should be hidden or
disabled.

Border Advanced Tab

This tab is available for all painters. It gives you the possibility to change the color
attributes of a painter dependently of a variable value (process point or container).
With 'Color Conditions' you can specify the minimum to maximum range of a
process point or container. You can choose between two or three colors for the
interior and for the outline color.
If you choose '2 colors on condition' you can compare a variable against 0 or 1 and
define the corresponding color for the interior and the outline of the painter.

Furthermore you can activate the interior and outline color based on a condition.
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Text Positions Advanced Tab

This tab is available for 'Button' and 'Static Text' painters. The 'Text Positions
Advanced' tab gives you the possibility to center and align the text within the
painter. Each align you can activate on a condition.

Bargraph Advanced Tab

The 'Bargraph Advanced' tab is only used for the bargraph painter.

Source Ranges: configure the min. and max. value that should be
displayed. The min. value belongs to an empty bargraph
(0 %) and the max. value to a full bargraph (100%). The
process point to be represented can be configured in the
Repaints-tab of the property dialog.

Orientation: sets the orientation of the bargraph
Scale: configures the scale spacement and visibility.
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Line Advanced Tab

The 'Line Advanced' tab is only used for the 'Line' painter. Here you can define if
the line should have an arrow at the beginning, the end or at both sides.

Painter Configuration Window

At the bottom left of the main window there is the painter configuration window.
Each time you select a painter in a graphical teq-view, its main properties were
displayed in the configuration window. Main properties are the repaints and action
settings of the painter. Furthermore all text strings including symbolical references
were listed in a cross-reference section. There you can change a string by right-
clicking on it and selecting 'Rename Info'.
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Function Key

The 'Function Key'-tab is only available for button painers. For each button you can
define a keyboard shortcut.
The keys 'F1' to 'F12' have a special syntax. You have to define 'FKEY_1' for the
key 'F1' for example ('FKEY_1'...'FKEY_12').
If you defined 'FKEY_1' as the function key, the user can press 'F1' on the
keyboard (this will trigger a mouse down event).
This works only in MicroBrowser not in a java-applet webbrowser client.

Multiline-Repaints

The 'Multiline-Repaints'-tab is only available for multi line painters. You can type in
a static multiline text into the field 'Multilined String'.
If you activate 'Auto adjust multiline text' the painter will automatically insert a
carriage return in the displayed text if its length exceeds the painter's width.
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If you choose 'HTML TAG' as the source type you can work with language
dependent csv files. In the csv file you have to work with '\n' (as two characters) to
make a new line:

line1\nline2\nline3
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1.24.3 Group Functions

Group/Ungroup

By grouping together several painter objects you can modify the properties of the
individual painters together. Furthermore, such a group of painter objects can be
stored as library macro and reused in new S-Web Editor projects.

First you have to select the painters, which should be in the group. (Hold on
SHIFT and click on the painters or draw a frame around the painters with the
left mouse button pressed). To group the selected painters click on the
group symbol in the toolbox

To ungroup the selected group, click on ungroup symbol in the toolbox

To edit the groups properties make a double click on the group and the Group
Dialog will appear.

Group Dialog - Advanced Select Tab

The 'Advanced Select Window' gives you the possibility to edit all painters in the
group. Double click on the group of painters you want to configure and the property
dialog of this group will appear.
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Group Dialog - General Tab

Here you can set some common properties like size, position, color, border and
font. For each property you can indicate if it should be a common property for all
the painters in the selection or not.
You can set common properties for the painters you have selected, or for one
before created group (not both at the same time).

Press 'OK' to confirm your modifications.

Activate the checkbox 'Set Group Properties' if you have selected a group.
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Cross Reference

In the 'Cross Reference' window you can redefine all the strings and references
used by the individual painters in the group. In the example below is a string used
by one painter in the group. Selecting it will copy it to the edit field at the top of the
dialog tab. Now you can change it to your desired value and update it by pressing
the button 'Update'. This function is very useful if you have a lot of painters. If you
have a group with many buttons, you can define other references for all buttons by
one click. Simply select the painters you want to set a reference and type the new
reference in the edit box, after this click on the 'Update' button.

With the button 'Find/Replace' you can quickly change all occurrences of a string
or substring.

Use 'Macro Find/Replace' to quickly change all occurrences of group names in
macros.

The colour information (R,G,B values) you see in the Cross Ref screenshot above
was defined in the 'Border Advanced' tab of a Bargraph Painter:
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1.24.4 Library Functions

With the library functions you can easily store your own painters in a library. The
library is a directory called MacroLib which resides in your PG5 program

directory.

Adding A Painter Object To The Library

After having designed your own painter by the use of the basic painters you can
group them together using the group functions described above and select out of
the Library menu the command Insert object into Library... A

dialog will appear where you can give your object a filename (extension *.tlb) and
store it into the "MacroLib" directory.

Inserting A Painter Object From The Library

With the menu function Library->Get object from library... you can

insert a library object into the active teq-view. After having inserted such an object
you normally should alter its references. This is done by double-clicking on it
which will pop up the group dialog. Select the Cross-reference tab and change the
references according to your needs.
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Removing A Painter Object From The Library

With the menu function Library->Remove object from library.. you

can remove and delete a library object. A file selection dialog will appear where you
can select the object(s) to be removed.

Modify Macro From Library

With the menu function Library->Remove object from library.. you

can modify an existing library object. You are not able to overwrite existing
macros.

Please see also chapter 'Working With Macros'

 

 

1.24.5 Custom Color Dialog

Every time you define a color in the S-Web Editor the custom color dialog will be
shown.
This dialog allows you to pick up one of the basic colors or to define your own
custom color.

To define a custom color simply pick a color from the color matrix or define a
specific RGB value and click 'Add to Custom Colors'.
The already defined custom colors will also be shown in this dialog.

If you close the S-Web Editor the custom colors will be lost!
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1.25 Painter Reference

The painters have a predefined set of action and repaint events, which cannot be
modified. For the 'Professional Edition' Editor user, these objects can be a set of
base objects which can be modified and extended. The gallery painters are based
on the basic painter types, which are shown inside the 'Painter' toolbox.

· Static Painter Objects

· Dynamic Painter Objects

 

1.25.1 Static Painter Objects

The following painters cannot be connected to any external data sources. They are
design elements. For the general and specific properties see chapter 'property
window'.

Rectangle, Ellipse, Polygon

These painters gives you the possibility to set some conditions, depending if they
are true or not, the color properties will be changed automatically. To set these
conditions click on the tab 'Border Advanced' in the property window.

Line

The line painter has the same properties as rectangle, ellipse and polygon.
Additionally you can specify in its own properties dialog tab, if you want to
have the line with an arrow at the beginning, the end or at both sides of the
line.

 
Image
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This Image view painter displays and updates a GIF or XBM formatted image
file. The user can define up to three different images that are displayed as a
function of a condition. The condition input is read from the web-server (as a
process point) and compared to a value, which must be defined as a private
property. More than one image can be displayed at the same time if the
images have a transparent background. The conditions can refer to the same
or different process points. The images will be scaled to the size indicated in
the common properties. The image files could reside on the web-server this
applet is loaded from or in the local directory ..\webpages. The interior color
will be visible as a background if the images have a transparent background.

Multi Line Label

The Multine Line Label painter displays a multi line text. The source type is a
static text string or a language dependent html tag.
Please see chapter Property Window for details.

 

 

1.25.2 Dynamic Painter Objects

The following painters have an interactive behaviour and their properties can be
edited in property tab (double click on painter). Some of these painters have the
capability to write or modify process points on the server. Any modification, which
is done by the user, will be written instantaneously to the target. It can take a
short time until the new value is updated in the browser view because the new
value has to be reloaded from the target first. This mechanism makes sure that the
values, which are displayed inside the browser, are indeed identical to the
corresponding variables in the PCD System.

Static text
 

In the properties of the static text painter you can set some conditions, depending
if they are true or not, the color properties will be changed automatically. To set
these conditions click on the tab 'Border Advanced' in the property window. You
have a additional tab to configure the text position exactly, click on 'Text Positions
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Advanced' in the property window. To show a string, click on Edit a Source in the
Repaints tab and type your text in the name field.

Edit box

This painter displays and updates a process point from the webserver it was
loaded from. When you click on it inside the browser the value can be modified and
be written back to the target by pressing "Enter". The process point can be both,
text or a number.
The 'Text Position Advanced' boarder advanced is available, see 'Static text' painter
for the description.

Button
 

You can change the displayed string on the button in the property window (double
click on the painter) and 'Edit a Source' in the 'Repaints' tab true and type your
string in the field 'Name'.

With the function URL Jump causes the browser to jump to a HTML page. The
page to jump to is indicated with an URL. This URL can be located on the same
web-server as well as on any other webserver, which is currently available. To jump
to a local HTML page, it is sufficient to indicate the (path and) file name. e.g. 'help.
html'. To jump to another server, it is necessary to indicate the complete URL. e.g.
'http://192.9.225.60/help.html' or 'http://www.ininet.ch/index.html'. Set the 'URL
Jump' checkbox true and type the URL in the Field 'URL'.

With the function View Jump the browser to jump to another view inside the same
applet. The page to jump to is indicated with an integer. This integer refers to the
teq file number. For details on the numbering scheme inside an applet, see the
section 'Multiple Views' inside this manual. Set the 'View Jump' checkbox true and
type the index number of the teq view where the browser should jump to, in the
field 'view index'.
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Bargraph
 

The 'Bar Graph' painter is able to display a process point in a graphical
representation. To enable the desired functionality, the user must indicate the
range minimum and maximum of the respective process point.
See chapter Property Window for more information's about the 'Bargraph Advanced'
tab.

 

1.26 Trouble Shooting

1.26.1 Critical Issues With Larger Web Editor Projects

1. Maximum size of Web Editor projects

To determine the maximum size of Web Editor projects, the crucial figures are the
maximum number of PCD data points (PPOs) and/or the maximum number of TEQ
pages (views). These limits are mainly determined by the size of the RAM disk in
the PCD Web Server. The behaviour and the use of the RAM disk are explained in
Section 2 of this document. For the beginning of 2006, new official firmware
versions are planned, which will resolve the RAM disk problems. $ versions are
already available (see 2.2). Depending on the project size and the type of
communication link (e.g. modem, gateway), it may also be necessary to modify
other timing parameters. These are described in section 3.

2. RAM disk

The maximum RAM disk size is dependent on the PCD type:

PCD type FW version max. RAM disk [kB]
PCD3.Mxxxx 010 32

PCD2.M480 020 32

PCD2.M170 017 32
PCD2.M150 $C6 32
PCD1.M1x5 0A1 32
PCS1.Cxxx 01A 5

The RAM disk should always be set to the maximum size. In the firmware versions
listed
above, the default setting represents the maximum value.
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2.1 What is RAM disk used for?

Where a browser (or Java applet) reads the PCD variables (R/T/C/I/O etc.) with the
CGI functions "OrderVal.exe" and "ReadFile.exe", matching files are stored in the
RAM disk. Web projects created with the Web Editor use these functions.

The size of the files in RAM disk is dependent on the number of PCD data points
(PPOs).

The following values apply:

PCD type
from
firmware
version*

max. RAM
disk size

max. no. of PPOs
with fw version*

max. no. of PPOs
with older fw

PCD3.Mxxxx $18 32 1500 600
PCD2.M480 $22 32 1500 600
PCD2.M170 020 32 1500 600
PCD2.M150 $C6 32 1500 -
PCD1.M1x5 0A1 32 1500 600
PCS1.Cxxx BA5 5 250 100

The following formula was used to calculate the maximum number of PPOs:

(Max RAM disk size)/20 bytes = Number of PPOs

20 bytes is an average value for PCD media access (e.g. PDP,,R8000,d).

The maximum values listed above assume that the RAM disk contains only one
file. This will be the case where the "order per view" option is not set in the Web
Editor, i.e. the PCD variables from all TEQ views (screen pages) are refreshed
cyclically from a single Project Data File.
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If the maximum number of PCD variables is exceeded in a given project, older
firmware versions may cause the PCD to crash. In systems with new versions, all
PCD variables are no longer refreshed, and a "No message" error will be displayed
in the browser. There will also be an entry "WEB RAM TOO SMALL" in PCD
history.

Where the RAM disk contains multiple files, the number of values per file will be
reduced accordingly.

When does a RAM disk contain multiple files?

If the "Order per view" option is set in the Web Editor, a separate file will be saved
to the RAM disk for every web page (TEQ view) called. In this case, only the PCD
variables for the TEQ view (web page) visible in the browser will be read cyclically
by "OrderVal.exe" and "ReadFile.exe". This has the advantage that shorter refresh
times can be achieved.The disadvantage of this option is that a separate file is
saved to the RAM disk for every TEQ view. Once a page has been called, the file
stays in RAM disk. The number of files in RAM disk is restricted, limiting the
maximum number of TEQ views in a Web Editor project.
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The maximum number of TEQ view pages with the "order per view" option set is
dependent on the PCD type and firmware version:

PCD type
from
firmware
version*

max. RAM disk
size

with fw version* with older fw

PCD3.
Mxxxx

$18 32 32 12

PCD2.M480 $22 32 32 12
PCD2.M170 020 32 32 12
PCD2.M150 $C6 32 32 -
PCD1.M1x5 0A1 32 32 12
PCS1.Cxxx BA5 5 0 0

The "order per view" option should not be used with the PCS1 (RAM disk too
small).

If the maximum number* of TEQ files is exceeded in the Web Editor, the "order per
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view" option must not be used with the fw versions listed above.

If the maximum number of TEQ pages is exceeded in a given project, older
firmware versions may cause the PCD to crash. In systems with new versions, a
"No message" error will be displayed in the browser.

With larger Web projects, we strongly advise you to use the latest firmware
versions.

2.2 Solution to RAM disk problems

Particularly for large projects with many PCD variables, it would be helpful to set
the "order per view" option to enable short response times within a TEQ view.
However, we then run up against the maximum number of TEQ views per project.

As a short-term solution, the following solution has been implemented:

When the RAM disk is full, it is re-initialised and all files deleted. For the page
visible in the browser, "OrderVal.exe" is invoked immediately to write a new file to
the RAM disk; the PCD variables are then read cyclically with "ReadVal.exe". As
soon as the maximum number of pages have been retrieved in the browser and the
RAM disk is full again, it is automatically erased again. It is not apparent to the
user that the RAM disk has been re-initialised and erased. This also means that,
even with the "order per view" option set, the maximum number of pages in a Web
Editor project is no longer limited. The maximum number of data points mentioned
above will still apply.

This behaviour will be implemented as quickly as possible in the form of $ versions
for all PCD systems, no later than the end of 2005. At the beginning of 2006,
official firmware updates will then be introduced into production. This will resolve
the RAM disk problem, and the project limits described under 2.1 will no longer
apply.

3. Setting the timing parameters

In principle, the timing behaviour of access to the web pages can/must be set in
four other places:

a)
The priority of the Web
Server "task" in the PCD

(can be set in the Web Builder)

b)
The Response timeout for
the S-Bus

(can be set in WebConnect)

c)
Communication (request)
timeout for the S-Bus

(can be set in the Web Builder)

d)
The refresh time for the
Java applet

(can be set in the Web Editor project)

 
a) The priority of the Web Server "task" in the PCD
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This setting defines how the CPU
should split its capacity between
the Web Server and the PLC
task. The higher the priority, the
more CPU time is used for the
Web Server task, and the shorter
the response time achieved.

The example on the right should
be interpreted as follows:
for 21 ms, the CPU processes
the "normal" user program; for 4
ms, the Web Server task is
processed.

b) The response timeout for the S-Bus in the WebConnect software

On the WebConnect Setup
page (where the connection
to the PCD is configured: 
http://localhost/setup), a
"Response timeout" can be
defined.
For every telegram sent
from the WebConnect
software to the PCD, the
software waits this long for
a response from the PCD.
This "Response timeout"
only needs to be
considered in the case of
modem communication or
Web Server access via a
gateway.
With modem
communication, a minimum
timeout period of 4 seconds
has to be defined.

c) Communication timeout (Request timeout) for the S-Bus in the
Web-Builder

The key combination "CTRL + Saia" can be used to call up the hidden Advanced
Settings menu in the Web-Builder.

The Communication timeout must be adjusted on a PCD Web Server station
accessed via a modem or a PCD gateway. This timeout must be set to a higher
value than the "Response timeout" mentioned above. As a rule of thumb, it could
be set twice as high.

What is this timeout used for?

With S-Bus, WebConnect has to issue several S-Bus requests before a web page
is completely loaded. The Communication timeout is the maximum time between
requests. If this time is exceeded, the Web Server performs a reset and the
requested
page is not displayed in full.

http://localhost/setup
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d) Refresh time of the PCD variables with the Java applet in the
Web Editor

This parameter defines the refresh time for the PCD variables in the web browser.
The parameter is set in the Web Editor under "Project - TEQ Configurations", in
the "period" field under "applet params".
If the refresh time is too short, the applet will send a new request to the PCD as
soon as the PCD has responded to the preceding request.

To avoid an unnecessary communication load, the refresh time should be set as
high as possible.
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1.26.2 WYSIWYG For Fonts

The principle of WYSYWYG (what you see is what you get) in S-Web Editor
related to font size and font style is restricted. An absolutely identical behaviour on
all different platforms (Editor, Java Clients on different OS's, MicroBrowser XP, CE
and embedded) cannot be guaranteed due to fundamental differences in font
handling and font libraries.
The font as you see it in the S-Web Editor doesn't look like the same as on client
during runtime in every case.
This is because not every client (MicroBrowser, Sun VM or Microsoft VM) has the
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same font resources as available in the S-Web Editor.
If you choose a specific font and size in the S-Web Editor that is not available on
your client. Then the client will automatically choose a font which is similar to the
defined one.
E.g., if you choose a font style that is only available in a larger font size, it can
cause problems in displaying text fields because your text fields are maybe too
small. To solve this problem, choose another font size or enlarge the text field. To
improve the results dealing with this issue, it is recommended to use text fields
that are up to 20% larger than the size that is displayed in the editor. The 'Tahoma'
font will produce the best results.

Refer to the chapter 'Working With MicroBrowser' for details about fonts in
MicroBrowser.

1.26.3 Error Messages

This chapter describes error messages and possible solutions.

Problem
:

Painter displays errors like:
- syntax error in tag
- no components selected
- No Message

This means the applet has a problem in getting the PPO value of that
painter

Solution
:

1. Make sure having defined right formats for all PPOs in your S-Web
Editor project.

For PCD-text make sure having used the 'string' format in the
'init PPO' dialog

Refer to the chapter 'Initialising Processpoints (PPOs)' for details
about PPO formats.

2. Then make sure having regenerated the *.wsp file for your PG5
project (webbuilder)

3. Then make sure having rebuild your PG5 project and downloaded on
target after modifications on your S-Web Editor project
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